Network share timeouts?

Discussion, questions and support.
Post Reply
Message
Author
kevmeist
Posts: 38
Joined: 31.01.2014, 14:16

Network share timeouts?

#1 Post by kevmeist » 22.03.2015, 12:53

I notice when I have my server off and have FC configured to see those shares that FC takes a long time coming up when first invoked (timeouts?) and then "often" shows me the blue circle (waiting) when I try to do anything (about 20-30 seconds each time).

Are there any configuration parameters to minimize or stop this?

Thanks!

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: Network share timeouts?

#2 Post by Free4all » 22.03.2015, 21:12

I have noticed this as well. I don't know of a solution, but perhaps others do.

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: Network share timeouts?

#3 Post by joby_toss » 23.03.2015, 17:22

Did any of you try this .ini command?

NetworkLoadOnPrgStart=0 - disable auto loading network on program start

Or maybe I misunderstood the issue... wouldn't be the first time. :)

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: Network share timeouts?

#4 Post by Free4all » 20.04.2015, 09:03

Good question.

Isn't that the ini option for "Load network in background process when FreeCommander starts"? (might be slightly different wording, as I use my custom UI file)

Mine was set to 1 (checked) . I just tried changing it to 0 (unchecked). I'm pretty sure I used to have that option unchecked, but toggled it on due to network stalls within FreeCommanderXE. IIRC, setting it to 1 (checked) helped a little, but I don't quite remember. I have it set to 0 now (unchecked), and will see how it works.

What I report for sure is that while it was set to 1 (checked) there were problems. I'll report back as to how it works set to 0 (unchecked).

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: Network share timeouts?

#5 Post by Free4all » 24.04.2015, 07:46

joby_toss wrote:Did any of you try this .ini command?

NetworkLoadOnPrgStart=0 - disable auto loading network on program start

Or maybe I misunderstood the issue... wouldn't be the first time. :)
As promised, I've been doing some testing with the setting you recommended. It seems to help a little, but it is hard to tell due to caching. Overall, the "laginess" continues, but delays seem a touch shorter.

BTW, do you recommend using that option in conjunction with Windows or FCXE performing network operations (configurable via Settings)?

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: Network share timeouts?

#6 Post by joby_toss » 24.04.2015, 15:25

Look, I have a very small home network (3 PC's) and I use XE to access it without any issues.
I just added the shared folders to favorites and this is the only way I access them. Every time I hit a favorite shared folder, XE switches the view almost instantly.
I never use the tree (only 2 panes view for me).
I have NetworkLoadOnPrgStart=0 set in my .ini file.

P.S. I just tried build 685 public using the default settings. I accessed the Network through the Tree, than navigated to one of the 3 PC's and opened a shared folder and XE still did it almost instantly. Maybe it's just my simple home network set-up, but I have no problems...

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: Network share timeouts?

#7 Post by Free4all » 25.04.2015, 19:53

Thanks Joby!

That's great information. Why? Because it demonstrates a case when everything works well. :)

It sounds like, even with the tree shown, everything works as expected for you.

Maybe it is other settings causing problems for other users?

Screenshots of some of your settings that could possibly affect performance may help.

Can you upload screenshots for:
Settings>Network
Settings>File/folder operations>Drag&Drop
Settings>Select items
Settings>View>File/folder list>General
Settings>View>File/folder list>Icons
Settings>View>File/folder list>Refresh
Settings>View>Folder Tabs>Tab Management
Settings>View>Tree>Management
Settings>View>Drives>General
Settings>View>Drives>Select drive

Do you mind posting your .ini settings file? I would like to recreate your setup and see if I can get it to work. Doing so will hopefully determine which setting or combination of settings cause the problems (if it is related to settings).

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: Network share timeouts?

#8 Post by joby_toss » 26.04.2015, 05:43

Sure, but I don't think these settings matter more than the network configuration (stations number, servers, routers, switches, firewalls etc.).

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

As for my .ini config file, sorry I can't make it public for anyone to see in its entirety (there are some personal file paths that I removed), but here is a pastebin with the most relevant content (2 parts because of my free account limitations):
http://pastebin.com/FUDTtkBB
http://pastebin.com/RkqNgph5

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: Network share timeouts?

#9 Post by Free4all » 26.04.2015, 19:33

joby_toss wrote:Sure, but I don't think these settings matter more than the network configuration (stations number, servers, routers, switches, firewalls etc.)...
Thanks Joby. I'll take a look at it and do some testing (will take some time).

I've set up a set up a simple test network to test it all out. I set up a network with just two workstations on their own router, and the FCXE stalling/lagging problem is evident.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests