White border around custom icons

Bugs and issues.
Post Reply
Message
Author
Free4all
Posts: 246
Joined: 30.09.2014, 19:12

White border around custom icons

#1 Post by Free4all » 26.11.2017, 19:02

When using custom icons for the toolbar, a white border is created around the non-transparent pixels of the icon. Can you please turn off the creation of that white border (or at least make it an option)?

FCXE v760 beta 32-bit on Windows 7 64-bit

User avatar
Dreamer
Site Admin
Posts: 3442
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: White border around custom icons

#2 Post by Dreamer » 27.11.2017, 19:06

Could you provide a screenshot or/and upload the custom icon, please? I can't reproduce, tested with few icons.

EDIT: OK, I can reproduce with some icons.

mauimaui
Posts: 21
Joined: 15.11.2017, 01:16

Re: White border around custom icons

#3 Post by mauimaui » 29.11.2017, 02:12

In my blue-purple interface I'M using customized icons in the bars, I don't have any white border. I use always transparent background in icons generation .ico

I'M using as Icons old .dll files or icons extracted from old dll as well, in that case I can see a small white border around icons

FreeCommander XE 2017 Build 740 32-bit public

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: White border around custom icons

#4 Post by Free4all » 29.11.2017, 19:25

Dreamer wrote:
27.11.2017, 19:06
Could you provide a screenshot or/and upload the custom icon, please? I can't reproduce, tested with few icons.

EDIT: OK, I can reproduce with some icons.
Happy to hear you can reproduce the issue.

If you need some example icons, just let me know. BTW, I'm not seeing a way to attach icon files (or any files) here in the forums.

User avatar
Dreamer
Site Admin
Posts: 3442
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: White border around custom icons

#5 Post by Dreamer » 29.11.2017, 19:47

Here's an example, icons in the toolbar and the same icons in the FC panel.
Attachments
fcciconwhiteborderbug2Screenshot_11292017_204843.png
fcciconwhiteborderbug2Screenshot_11292017_204843.png (3.73 KiB) Viewed 12115 times
fcciconwhiteborderbugScreenshot_11292017_204449.png
fcciconwhiteborderbugScreenshot_11292017_204449.png (2.95 KiB) Viewed 12115 times

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: White border around custom icons

#6 Post by Free4all » 30.11.2017, 19:15

Dreamer wrote:
29.11.2017, 19:47
Here's an example, icons in the toolbar and the same icons in the FC panel.
Thanks Dreamer. That's exactly the issue.

It's interesting that it seems to only get applied to custom icons, not built-in icons.

For consistency, it would be best to remove the extra white border (or make it an option).

Free4all
Posts: 246
Joined: 30.09.2014, 19:12

Re: White border around custom icons

#7 Post by Free4all » 05.03.2019, 05:01

Just as a small update to this bug report, it is still present in FCXE 794 64-bit on Win7.

I tried something new: I added a Favorite Tool to the Splitter toolbar. When FCXE creates the icon from the executable tool, the icon looks good. If I extract the icon from the executable tool, and then specify the same icon in FCXE, the white border appears. I tried several different bit-depths and adding/removing an alpha channel from the icon file, but nothing was able to prevent the white border from appearing. I think this confirms that FCXE is treating icon files different than icons within executables (or built-in icons).

Hopefully this can be fixed.

stephen147
Posts: 161
Joined: 18.10.2015, 14:44

Re: White border around custom icons

#8 Post by stephen147 » 29.06.2019, 21:38

This issue even arises with the freecommander.exe file as an icon.

Some icons do work, most don't. So there must be a tool that can create icons that are compatible with FC.

I've created a duplicate issue on the XE as I didn't search this thread. Here: viewtopic.php?f=9&t=9612

See attached the problem with my custom icon. Notice the weird white halo effect around the icons.

Image

Then the fc.exe been used as an icon. (Same deal)

Image

Then there's these lot which work.
Attached are those ico files for anyone that can pinpoint why they work and others don't.
https://we.tl/t-7WVlv7s76e

Image
Sceenshots made easy with ShareX.

User avatar
Dreamer
Site Admin
Posts: 3442
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: White border around custom icons

#9 Post by Dreamer » 09.07.2019, 16:32

Another issue, I'm not sure if it was reported already, because the screenshots are lost from old topics.

In the favorite tools, the same icon (any, exe or ico) has the whe white border for "category", but it looks good for "item".

Test with the dark color schemes.

BTW Both, "category" and "item" icons look good in the toolbar, no white border.
Attachments
fcwhiteborderScreenshot_07092019_181856.png
fcwhiteborderScreenshot_07092019_181856.png (13.83 KiB) Viewed 8168 times

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests