Page 1 of 1

Windows Shortcut Run as Administrator not working

Posted: 06.07.2020, 22:52
by bladewolf55
Steps to Reproduce

1. Find an executable or batch file
2. Create a shortcut from the executable
3. In the shortcut's Properties > Shortcut > Advanced, check Run as administrator and save.
4. Double-click the shortcut to open the application

Expected Behavior: prompted by User Account Control to allow the operation
Actual Behavior: the application runs as non-administrator

More Information
The same shortcut works as expected when opened from Windows File Explorer.

The behavior is the same whe run using default settings and no plugins.

System Information
Version: FreeCommander XE 2020 Build 822 64-bit donor
OS: Windows 10 Pro Version 2004 (issue occurred in previous Windows 10 version as well)

Re: Windows Shortcut Run as Administrator not working

Posted: 07.07.2020, 18:58
by Dreamer
Can't reproduce with 810a 32-bit public, 822 64-bit donor, also with default settings, Windows 10 2004 64-bit.

Re: Windows Shortcut Run as Administrator not working

Posted: 09.07.2020, 07:14
by Plaw
Confirmed - this has been a problem for a long time in my case

Re: Windows Shortcut Run as Administrator not working

Posted: 09.07.2020, 18:45
by Dreamer
I'm using a portable version, try to install/unpack portable version to other folder than "Program Files".

https://freecommander.com/en/faq-freeco ... l-portable

Re: Windows Shortcut Run as Administrator not working

Posted: 10.07.2020, 04:14
by sherpa25
Dreamer wrote:
09.07.2020, 18:45
I'm using a portable version, try to install/unpack portable version to other folder than "Program Files".

https://freecommander.com/en/faq-freeco ... l-portable
May I ask what's the difference w/ the portable version, why would it work there instead? Also, what's the consequence of installing FC in "Program files"?

Re: Windows Shortcut Run as Administrator not working

Posted: 10.07.2020, 05:55
by Plaw
I have tried the portable version - same problem. I could not even get that shortcut to show the administrator sign despite setting it in the properties in at least two places

Version numbers:
Windows 10 1903
Free Commander XE 2020 Build 810a 32-bit public

I have 3 programs I have written in Delphi, including a payroll package, and none of these have this problem

Re: Windows Shortcut Run as Administrator not working

Posted: 26.07.2020, 05:15
by Plaw
Problem resolved - revert to version 790A

Re: Windows Shortcut Run as Administrator not working

Posted: 28.07.2020, 21:28
by bladewolf55
The problem remains running FC x64 build 824 using default settings, no plugins.

"C:\Program Files\FreeCommander XE\FreeCommander.exe" /N /NewIni=FreeCommanderTest.ini /NoPlugins /Lng=English

I don't doubt this was working in a previous version, e.g. 790A, because I knew it had changed. But reverting to an older version doesn't resolve the problem for me as I don't want to go backward.

For now, the workaround is right-click and choose Run as Administrator.

Re: Windows Shortcut Run as Administrator not working

Posted: 31.07.2020, 19:40
by bladewolf55
@Dreamer:

Behavior is the same using FC Portable version x64 825 installed to my Downloads folder. A shortcut or file set to Run as Administrator does not.

Re: Windows Shortcut Run as Administrator not working

Posted: 10.08.2020, 16:15
by bladewolf55
Working again in donor build 826 (64-bit). Thank you!