Auto selectable views not working

Bugs and issues.
Post Reply
Message
Author
rjut
Posts: 10
Joined: 11.08.2018, 13:48

Auto selectable views not working

#1 Post by rjut » 14.11.2020, 12:44

I am a long time user of FC and I love it. However, I have troubles to get the automatic views to work.

I started a new FC session with a new config file "testsettings" as suggested by the 'read this first' post.

Goal is to always show my downloads folder in descending dates order (so file with newest date on top). Used these steps:
  • created an auto view and called it 'Downloads'
  • set condition <mask>Downloads
  • selected Sort On: Date/Time and checked Descending
  • moved this view to the top, so view downloads first, followed by <Default View>
  • set the check box 'switch view mode automatically on folder'
This results in the following FreeCommander.views.ini file

[FcAutoSelectableViews]
1=asv_189212CD-7BFD-48B1-BD30-30F4D56FA395
2=asv_7D2049A9-9507-4693-BE47-6A7965418653
ActivateAutoSelection=1

[asv_189212CD-7BFD-48B1-BD30-30F4D56FA395]
Id=189212CD-7BFD-48B1-BD30-30F4D56FA395
Name=Downloads
ViewStyle=0
DetailedViewName=
DetailedViewAutoSelect=0
SortColumnContentType=0
SortColumnContent=9
SortAsc=0
Condition=<mask>Downloads
ContentConditionType=0
ContentCondition=

[asv_7D2049A9-9507-4693-BE47-6A7965418653]
Id=7D2049A9-9507-4693-BE47-6A7965418653
Name=<Default view>
ViewStyle=2
DetailedViewName=
DetailedViewAutoSelect=1
SortColumnContentType=0
SortColumnContent=0
SortAsc=1
Condition=
ContentConditionType=0
ContentCondition=

Then do the following:
  • select folder "C:\Users\Ron"
  • click on name column to sort ascending on names
  • double click on the downloads folder (C:\Users\ron\Downloads)
... the downloads folder is shown but the view is NOT changed as expected! It remains sorted on name asc.

I have tried different masks such as Downloads, *Downloads and *ownloads with the same result.
Can't think of anything I am doing wrong, is this a bug?

PS I have never been able to get auto views to work also on previous versions. This is the first time I tested it with a clean installation.
FreeCommander XE 2020 Build 832 64-bit donor, Windows 10 Pro 64-bit 20H2

User avatar
Dreamer
Site Admin
Posts: 4252
Joined: 19.08.2007, 23:40

Re: Auto selectable views not working

#2 Post by Dreamer » 14.11.2020, 15:50

Do you have the option "[v] Switch view mode automatically on folder change" in Settings - Auto selectable view checked?

rjut
Posts: 10
Joined: 11.08.2018, 13:48

Re: Auto selectable views not working

#3 Post by rjut » 14.11.2020, 23:55

Yes, As mentioned in the last bullit, the checkbox 'switch view mode automatically on folder' is checked.
FreeCommander XE 2020 Build 832 64-bit donor, Windows 10 Pro 64-bit 20H2

User avatar
Dreamer
Site Admin
Posts: 4252
Joined: 19.08.2007, 23:40

Re: Auto selectable views not working

#4 Post by Dreamer » 15.11.2020, 00:54

I can't reproduce in the same version 832 donor, re-check your settings or perhaps share a screenshot from the Settings dialog - Auto views.

BTW Version "FreeCommander XE 2020 Build 832 64-bit public" does NOT exist. Which version are you using for real?

FAQ – FreeCommander

Marek
Author
Author
Posts: 2954
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: Auto selectable views not working

#5 Post by Marek » 15.11.2020, 22:12

Goal is to always show my downloads folder in descending dates order (so file with newest date on top). Used these steps:

created an auto view and called it 'Downloads'
set condition <mask>Downloads
selected Sort On: Date/Time and checked Descending
moved this view to the top, so view downloads first, followed by <Default View>
set the check box 'switch view mode automatically on folder'
You have made all correctly.
Unfortunatelly automatic view does not work in that case because the "View type" is set to <No change>.
I have fixed it for the next release.

rjut
Posts: 10
Joined: 11.08.2018, 13:48

Re: Auto selectable views not working

#6 Post by rjut » 17.11.2020, 21:30

From the help, I am using
FreeCommander XE 2020 Build 832 64-bit donor
Changed my signature accordingly.
FreeCommander XE 2020 Build 832 64-bit donor, Windows 10 Pro 64-bit 20H2

rjut
Posts: 10
Joined: 11.08.2018, 13:48

Re: Auto selectable views not working

#7 Post by rjut » 17.11.2020, 21:35

For what it's worth, I can confirm that when I change 'View type' from '<No change>' to 'details' it works now as expected.
@Marek, thanks for the help.
FreeCommander XE 2020 Build 832 64-bit donor, Windows 10 Pro 64-bit 20H2

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests