Page 1 of 1

highlighting in search is not working for xml files

Posted: 07.06.2016, 08:07
by need4speed
when searching for a containing text "cod" in the settings Folder,
a XML file containg the string is found but after selecting the search string
highlighting does not work. after selecting the string in the text field it turns red.

highlighting seems to work for ini and shc files.

Image

Re: highlighting in search is not working for xml files

Posted: 07.06.2016, 14:16
by afh
I think (but I'm not sure) you have to go to Configure Viewer.

Select a xml file then F3, then F9.
In "Configure Viewer" -> "General" add ".xml" to "as Text", and remove ".xml" from "as Internet/Office".
From now on, F3 will open xml files as Text.

Re: highlighting in search is not working for xml files

Posted: 07.06.2016, 21:44
by need4speed
changing the extensions as you suggested did not work for me.
for some reason the settings were not saved, too late 4 me to investigate the issue.

but hey, i found another work-around and a (potential) bug. :lol:
actually you don't need to change the extensions,
you may right click on the title in the quick view section to change to "text" or press the dang shortcut.

unfortunately the highlight toolbar is hidden after the change. I did not find a way to get it back only via
a work-around by quick filtering the file name, the tool bar simsalabim re-appeared.

Image

Re: highlighting in search is not working for xml files

Posted: 17.12.2018, 12:04
by tgeza
You have to uncheck the Auto-detect textfiles checkbox on the Viewer's Settings popup in order not to auto-rollback your setting at the next time when you open an XML file.