Shortcut with circumflex is not saved

Bugs and issues.
Post Reply
Message
Author
kimma123456
Posts: 5
Joined: 12.08.2016, 21:33

Shortcut with circumflex is not saved

#1 Post by kimma123456 » 12.08.2016, 21:45

Hi,

this bug is somewhat weird because it only happens when I assign a shortcut with the circumflex (the key left to number 1 and above tab). Modifying other shortcuts works as expected and they are saved.

Behavior: Change shortcut of "Set active panel" to Alt + ^. This shortcut then work until the session ends, and apparently is also written to the shortcut config (FreeCommander.shc). However, after closing and starting FC again, the shortcut is back to the default combination (Tab).

The key '^' is usually a dead key, meaning it is used with other characters to print accented characters, i. e. such as the â. However, I turned off this behavior by modifying the keyboard layout. This problem even persists when I changed back to the normal keyboard layout.

I have tried reinstalling FC but it didn't help.

FreeCommander XE 2016 Build 715 32-bit public
on Windows 7 SP1 64 Bit

horst.epp
Posts: 154
Joined: 15.11.2008, 19:18

Re: Shortcut with circumflex is not saved

#2 Post by horst.epp » 13.08.2016, 12:06

And what is the real need behind this strange idea ?

kimma123456
Posts: 5
Joined: 12.08.2016, 21:33

Re: Shortcut with circumflex is not saved

#3 Post by kimma123456 » 13.08.2016, 16:34

horst.epp wrote:And what is the real need behind this strange idea ?
Why is that considered a strange idea? People have different needs and preferences, I prefer to use Alt + ^ to switch between windows within a program, which resembles the Alt + Tab behavior to switch between open windows.
Secondly, this is a bug after all and in my opinion should be viewed as a misbehavior rather than what people's use cases are.

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: Shortcut with circumflex is not saved

#4 Post by Marek » 13.08.2016, 17:55

It works for me fine - after closing and starting FC too.
What is the value for the shortcut in the shc file? What is your Windows language?

kimma123456
Posts: 5
Joined: 12.08.2016, 21:33

Re: Shortcut with circumflex is not saved

#5 Post by kimma123456 » 14.08.2016, 07:06

Marek wrote:It works for me fine - after closing and starting FC too.
What is the value for the shortcut in the shc file? What is your Windows language?
FreeCommander.shc
actViewSetActivePanel=Alt+^

Windows language is German

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: Shortcut with circumflex is not saved

#6 Post by Marek » 14.08.2016, 07:21

Could you check with the following value:

actViewSetActivePanel=Alt+ZIRKUMFLEX

kimma123456
Posts: 5
Joined: 12.08.2016, 21:33

Re: Shortcut with circumflex is not saved

#7 Post by kimma123456 » 15.08.2016, 00:12

Marek wrote:Could you check with the following value:

actViewSetActivePanel=Alt+ZIRKUMFLEX
It still does not work, unfortunately.

Just FYI: I tried to work around the problem by looking up how the same shortcut (Alt+^) is saved for another program in which I also switch between active panels (RStudio). The shortcut surprisingly was saved as Alt+6, which I tried setting up in the .shc file but it did not solve the problem. The shortcut Alt+6 was correctly saved and interpreted by FreeCommander though. Don't know if this information helps. I think there is an issue with the circumflex.

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: Shortcut with circumflex is not saved

#8 Post by Marek » 16.08.2016, 20:39

I have testet it on German Win 7, Win 8.1 and Win 10 - it works fine.
Always will be Alt+ZIRKUMFLEX saved.
I think, your Windows is not German or some Windows setting make the problem.

Maybe someone with English Windows can test it?

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: Shortcut with circumflex is not saved

#9 Post by joby_toss » 17.08.2016, 03:39

Tested XE 715 x86 public portable on Windows 10 x64 English version with Romanian keyboard layout: it works as expected (Alt+` shortcut is saved across sessions).

Note that my "`" symbol is different than your "^" symbol.
Image

kimma123456
Posts: 5
Joined: 12.08.2016, 21:33

Re: Shortcut with circumflex is not saved

#10 Post by kimma123456 » 17.08.2016, 12:51

Hi all,

OK, I figured it out. Apparently this behavior was caused because of the dead key which I deactivated with a new keyboard layout (German). When I switched back to a English or German default keyboard layout, everything works as expected. Now I have to figure how I should handle this dilemma (disabling dead keys vs. switching windows within FC). This bug can however be closed I assume.

Sorry for the trouble that I caused.

Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 74 guests