748 - Search history issues

Bugs and issues.
Post Reply
Message
Author
User avatar
Dreamer
Site Admin
Posts: 3137
Joined: 19.08.2007, 21:40
Location: Slovakia

748 - Search history issues

#1 Post by Dreamer » 24.06.2017, 10:14

- use default settings (I could reproduce it also with custom settings)

#1

- type anything in Search files/folders - File name field
- press Enter or click Find button
- type a different text in Search files/folders - File name field
- press Enter or click Find button
- click the [v] button to open history context menu
= history is empty
- close the Search files/folders
- re-open Search files/folders
- click the [v] button to open history context menu
= history items are listed

#2

- open Search files/folders
- in menu click Options > "Run in external process"
- type a new text within the File name field
- press Enter or click Find button
- new Search files/folders window is opened
- click the [v] button to open history context menu
= history is empty
- type a new text within the File name field
- press Enter or click Find button
= history is empty
- close the Search files/folders
- re-open Search files/folders
= history includes only previous items, new items (except the first) used with option "Run in external process" are missing (also after close/reopen Search window)

#3

- open Search files/folders
- in menu click Options > "Run in external process"
- type a new text within the File name field
- press Enter or click Find button
- new Search files/folders window is opened
- in menu click Options
= "Run in external process" and "Run in external process as admin" are greyed out (I'm not sure if it's a bug, but the checkbox is missing, so it looks like it's disabled, but it's enabled actually)
- close the Search files/folders
- re-open Search files/folders
= "Run in external process" and "Run in external process as admin" are not greyed out, with the correct checkbox

EDIT: If this is hard to fix/change, perhaps the menu option + shortcut (Ctrl+R / same as Refresh in program) could help, at least as workaround.

FC 748 64-bit, Windows 10 64-bit.

User avatar
Dreamer
Site Admin
Posts: 3137
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: 748 - Search history issues

#2 Post by Dreamer » 27.07.2017, 20:21

Partially fixed in 750.

- type anything in Search files/folders - File name field
- press Enter or click Find button
- type a different text in Search files/folders - File name field
- press Enter or click Find button
- click the [v] button to open history context menu
= history is OK
- in menu click Options > "Run in external process"
- type a new text within the File name field
- press Enter or click Find button
- new Search files/folders window is opened
- click the [v] button to open history context menu
= history includes only the last item, old items are missing
- close and re-open Search files/folders
= all history items are listed (OK)
- type a new text within the File name field
- press Enter or click Find button
- new Search files/folders window is opened
- click the [v] button to open history context menu
= history includes only the last item, old items are missing

- open Search files/folders
- in menu click Options > "Run in external process"
- type a new text within the File name field
- press Enter or click Find button
- new Search files/folders window is opened
- in menu click Options
= "Run in external process" and "Run in external process as admin" are greyed out

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests