Page 1 of 1

White border around custom icons

Posted: 26.11.2017, 19:02
by Free4all
When using custom icons for the toolbar, a white border is created around the non-transparent pixels of the icon. Can you please turn off the creation of that white border (or at least make it an option)?

FCXE v760 beta 32-bit on Windows 7 64-bit

Re: White border around custom icons

Posted: 27.11.2017, 19:06
by Dreamer
Could you provide a screenshot or/and upload the custom icon, please? I can't reproduce, tested with few icons.

EDIT: OK, I can reproduce with some icons.

Re: White border around custom icons

Posted: 29.11.2017, 02:12
by mauimaui
In my blue-purple interface I'M using customized icons in the bars, I don't have any white border. I use always transparent background in icons generation .ico

I'M using as Icons old .dll files or icons extracted from old dll as well, in that case I can see a small white border around icons

FreeCommander XE 2017 Build 740 32-bit public

Re: White border around custom icons

Posted: 29.11.2017, 19:25
by Free4all
Dreamer wrote:
27.11.2017, 19:06
Could you provide a screenshot or/and upload the custom icon, please? I can't reproduce, tested with few icons.

EDIT: OK, I can reproduce with some icons.
Happy to hear you can reproduce the issue.

If you need some example icons, just let me know. BTW, I'm not seeing a way to attach icon files (or any files) here in the forums.

Re: White border around custom icons

Posted: 29.11.2017, 19:47
by Dreamer
Here's an example, icons in the toolbar and the same icons in the FC panel.

Re: White border around custom icons

Posted: 30.11.2017, 19:15
by Free4all
Dreamer wrote:
29.11.2017, 19:47
Here's an example, icons in the toolbar and the same icons in the FC panel.
Thanks Dreamer. That's exactly the issue.

It's interesting that it seems to only get applied to custom icons, not built-in icons.

For consistency, it would be best to remove the extra white border (or make it an option).

Re: White border around custom icons

Posted: 05.03.2019, 05:01
by Free4all
Just as a small update to this bug report, it is still present in FCXE 794 64-bit on Win7.

I tried something new: I added a Favorite Tool to the Splitter toolbar. When FCXE creates the icon from the executable tool, the icon looks good. If I extract the icon from the executable tool, and then specify the same icon in FCXE, the white border appears. I tried several different bit-depths and adding/removing an alpha channel from the icon file, but nothing was able to prevent the white border from appearing. I think this confirms that FCXE is treating icon files different than icons within executables (or built-in icons).

Hopefully this can be fixed.

Re: White border around custom icons

Posted: 29.06.2019, 21:38
by stephen147
This issue even arises with the freecommander.exe file as an icon.

Some icons do work, most don't. So there must be a tool that can create icons that are compatible with FC.

I've created a duplicate issue on the XE as I didn't search this thread. Here: viewtopic.php?f=9&t=9612

See attached the problem with my custom icon. Notice the weird white halo effect around the icons.

Image

Then the fc.exe been used as an icon. (Same deal)

Image

Then there's these lot which work.
Attached are those ico files for anyone that can pinpoint why they work and others don't.
https://we.tl/t-7WVlv7s76e

Image

Re: White border around custom icons

Posted: 09.07.2019, 16:32
by Dreamer
Another issue, I'm not sure if it was reported already, because the screenshots are lost from old topics.

In the favorite tools, the same icon (any, exe or ico) has the whe white border for "category", but it looks good for "item".

Test with the dark color schemes.

BTW Both, "category" and "item" icons look good in the toolbar, no white border.