How replace WindowsExplorer for FreeCommander by defaut ?

Discussion, questions and support.
Message
Author
Cyberdome
Posts: 3
Joined: 15.09.2008, 10:15

How replace WindowsExplorer for FreeCommander by defaut ?

#1 Post by Cyberdome » 15.09.2008, 10:51

Hi,

How replace Windows Explorer for FreeCommander by defaut ?

When i click on a folder, it's open with windows explorer.


PS: Sorry for my bad english, i'm a bad student... and i'm french ;)

dcd_6
Posts: 1
Joined: 15.09.2008, 13:02

#2 Post by dcd_6 » 15.09.2008, 13:04

Cyberdome, I would love the same information.

1- I would like My Computer to default to FreeCommander
2- I would like Explorer to default to Free Commander
3- Any drive letter access from Run: also
4- File folders, etc.

Anyone have any thoughts?

User avatar
ralfso
Posts: 660
Joined: 31.10.2007, 17:21
Location: Gifhorn, Germany

#3 Post by ralfso » 15.09.2008, 17:33

What's about forum-search for:

default AND file AND manager

???
Regards
Ralf

Win10 (64-bit), Intel i7-2600 (3,4 GHz), 8 GB Ram, 2x2000 GB HD, NVIDIA GeForce 545

Cyberdome
Posts: 3
Joined: 15.09.2008, 10:15

#4 Post by Cyberdome » 15.09.2008, 19:14

thx

i found it:

Open a new file in an editor and copy the following:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@="\"C:\\Programme\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
[/color]

Change the path in the last line to your fc-install-directory.
If you want the folder to be opened in the left pane, change /R to /L .

To change it back to default use this:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@=""

[-HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
[/color]
but it doesn't work completely on my pc. After execute script_above.reg i click on any folder and computer say "there is no application associated with this file type".

Emralegna
Posts: 1
Joined: 19.10.2008, 17:23

#5 Post by Emralegna » 19.10.2008, 17:39

Salut Cyberdome,

As-tu bien modifier la ligne :

Code: Select all

@="\"C:\\Programme\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
pour qu'elle pointe vers ton dossier d'installation ?

Par défaut, ce devrait être :

Code: Select all

@="\"C:\\Program Files\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
Chez moi, j'ai séparé le dossier « Program Files » de la partition Windows pour l'installer sur D:\, donc j'ai modifier le C:\\Programme indiqué par D:\\Program Files et tout marche parfaitement. J'ai également changé le /R en /L car je préfère que le dossier fraichement ouvert soit sur le panneau de gauche.

En revanche je remarque qu'il n'y a pas de dossier Poste de Travail, mais tous les périphériques sont de toutes façons présent dans la barre des lecteurs, juste au dessus des onglets.

Voilà. :)

Cyberdome
Posts: 3
Joined: 15.09.2008, 10:15

#6 Post by Cyberdome » 19.10.2008, 18:24

Cette fois ça fonctionne merci. Pourtant j'avais bien modifié le chemin d'accès mais je crois que j'ai du faire un copié collé du chemin indiqué dans les propriétés de freecommander.exe , les antislashs étaient donc simple et j'ai du oublié de les doubler.

User avatar
Dreamer
Site Admin
Posts: 3089
Joined: 19.08.2007, 21:40
Location: Slovakia

#7 Post by Dreamer » 19.10.2008, 21:23

Please respect the forum rules:

• Post in English only.

You can use PM if you want to use another language. Thanks.

k3nt
Posts: 3
Joined: 31.12.2008, 22:53

To clarify: How To Replace Explorer With FreeCommander

#8 Post by k3nt » 31.12.2008, 23:13

To clarify:
How To Replace Explorer With FreeCommander

1. Open a text editor such as notepad (or my favorite "notepad++).

2. Paste the following text into a new document:
REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@="\"C:\\Program Files\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
3. Save the document as "replace-with-freecommander.reg" (name the document as "replace-with-freecommander.reg")

4. Open the document named "replace-with-freecommander.reg" (double click it).

5. Click "Yes" to the following pop-up: "Are you sure you want to add the information in ..\replace-with-freecommander.reg to the registry?

Done. Enjoy!
http://k3nt.info

wkrekik
Posts: 58
Joined: 24.10.2007, 09:14

Alternative solution

#9 Post by wkrekik » 02.01.2009, 10:16

This .reg file didn't work for me. I don't no why but I have found another way :

1. In freecommander : Settings-->Shell menu-->Add FC to context menu : tick folders and drives
2. Control panel--> folders options --> file type--> Go to Drives or Files folders, click on advanced, then set Freecommander as default.

So if the straightforward .reg file solution doesn't work for some reason, you can try this alternative one

jiZer
Posts: 1
Joined: 04.01.2009, 09:15

Re: To clarify: How To Replace Explorer With FreeCommander

#10 Post by jiZer » 04.01.2009, 09:31

k3nt wrote:To clarify:
How To Replace Explorer With FreeCommander

1. Open a text editor such as notepad (or my favorite "notepad++).

2. Paste the following text into a new document:
REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@=""C:\\Program Files\\FreeCommander\\FreeCommander.exe" /C /R="%1""
3. Save the document as "replace-with-freecommander.reg" (name the document as "replace-with-freecommander.reg")

4. Open the document named "replace-with-freecommander.reg" (double click it).

5. Click "Yes" to the following pop-up: "Are you sure you want to add the information in ..\replace-with-freecommander.reg to the registry?

Done. Enjoy!
It worked for me but i didnt like it that way so i wanted back like it was before so i deleted the reg key in the register. But now opens every map i doubleclick on in a new window it looks like this

Explore
Open

I want to get rid of the bold explore text like it was before.

User avatar
settle
Posts: 1
Joined: 06.06.2008, 15:20
Location: Lithuania
Contact:

Re: Alternative solution

#11 Post by settle » 04.01.2009, 19:21

wkrekik wrote:This .reg file didn't work for me. I don't no why but I have found another way :

1. In freecommander : Settings-->Shell menu-->Add FC to context menu : tick folders and drives
2. Control panel--> folders options --> file type--> Go to Drives or Files folders, click on advanced, then set Freecommander as default.

So if the straightforward .reg file solution doesn't work for some reason, you can try this alternative one
Thank you, works perfect :)

2Clicks
Posts: 2
Joined: 12.01.2009, 03:45

When using IE

#12 Post by 2Clicks » 12.01.2009, 03:51

Hi,

I've done both the options above and it works fine, EXCEPT when using Internet Explorer, say when attaching pictures to emails etc, Windows Explorer still opens for me to find the file/pic I want to attach.

Am I missing something?

Cheers

User avatar
ralfso
Posts: 660
Joined: 31.10.2007, 17:21
Location: Gifhorn, Germany

#13 Post by ralfso » 12.01.2009, 11:19

I think, this can not be replaced because it is a open/save-Dialog which always use Explorer.exe.
Regards
Ralf

Win10 (64-bit), Intel i7-2600 (3,4 GHz), 8 GB Ram, 2x2000 GB HD, NVIDIA GeForce 545

inkheart
Posts: 6
Joined: 25.02.2009, 07:25

back to default file manager

#14 Post by inkheart » 01.03.2009, 05:02

Cyberdome wrote:thx

i found it:

Open a new file in an editor and copy the following:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@=""C:\\Programme\\FreeCommander\\FreeCommander.exe" /C /R="%1""
[/color]

Change the path in the last line to your fc-install-directory.
If you want the folder to be opened in the left pane, change /R to /L .

To change it back to default use this:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@=""

[-HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
[/color]
but it doesn't work completely on my pc. After execute script_above.reg i click on any folder and computer say "there is no application associated with this file type".
I used the code to make FC as the default and it worked. But since FC keeps on crashing, I wanted to go back to the default settings. I followed the code to go back to the default and it worked. Thanks.

Krys
Posts: 2
Joined: 26.04.2009, 08:52

#15 Post by Krys » 26.04.2009, 08:58

Hey,

i used the clarification of k3nt to set up free commander the default explorer. But since that I can't open up the control panel anymore. It directs me to system32 in free commander.

I know within free commander is the control panel but clicking any entry has the same result.

any idea what went wrong? or how i can fix it to accesss my control panel entries again?

thx

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest