Problem Using Converter to Search for Text in PDF Files

Discussion and questions - donor version.
Post Reply
Posts: 3
Joined: 06.01.2021, 05:43

Problem Using Converter to Search for Text in PDF Files

#1 Post by cbthomas » 06.01.2021, 06:18

I recently upgraded to the Donor version of Free Commander; however, I have not been successful in configuring the Converter to be able to search for text within PDF files. I would appreciate any advice anyone could offer in solving this problem. I am providing the following information you may find relevant.

--I tried to configure the Converter on both my laptop and my desktop, without success. The desktop and laptop are both 64-bit machines running Windows 10.
--I used the following instructions to configure the Converter; these instructions are from the FreeCommander FAQs, the "FAQ - Search" section at this link: ... f-for-text

"For this example (Office files: docx, xlsx), you need do download, unpack and set up the converter tool. To do this:

Download the xdoc2txt tool from this page (it’s in Japanese, scroll down or search for “zip” to find the download link)
Unpack the xdoc2txt.exe file to your drive (e.g.: C:\Programs\xdoc2txt)
Open the FreeCommander and the Search files/folders dialog (Ctrl+F)
Switch dialog to “Converter” tab
Click the button “Add new row” (or the “Insert” key)
Add these items into the Filter field: *.pdf;*.doc;*.docx;*.odt;*.xls;*.xlsx
Add the path to the xdoc2txt tool file, e.g.: C:\Programs\xdoc2txt\xdoc2txt.exe
Add the Parameters: “%ConvertSourceFile%” >%ConvertTargetFile%
If you copy this text into the program via the clipboard, then re-enter the characters ” using the keyboard.
Select the checkbox for the actual Filter"

--Here is a sample error message I get when trying to search using the Converter after following the above instructions for configuring it:

[function: CreateDOSProcessRedirected] Function failure

Thanks for any help anyone can offer.

Posts: 3
Joined: 06.01.2021, 05:43

Re: [Solved] Problem Using Converter to Search for Text in PDF Files

#2 Post by cbthomas » 08.01.2021, 03:45

I've figured out the solution to this problem: the xdoc2txt.exe file must be in the same folder as the installation folder for the FreeCommander.exe file, as shown below. Before discovering this solution, I had the xdoc2txt.exe file in a different folder than the FreeCommander.exe file. Everything is working properly now; I can search for text within PDF files.

C:\Program Files\FreeCommander XE\FreeCommander.exe
C:\Program Files\FreeCommander XE\xdoc2txt.exe

In case this information might be helpful to others, I arrived at this solution by doing a Google search on "xdoc2txt.exe". One of the results of this Google search was the item "xdoc2txt.exe File Download & Fix For All Windows OS" at this link:

In the discussion on the website at the above link was this comment:

"The above paths are the common paths where this file is located, but does not mean that it must be stored in the above paths. The file should be stored in the actual installation path of the software."

Post Reply

Who is online

Users browsing this forum: No registered users and 25 guests