Page 1 of 1

FreeCommander XE 600 freezes at start

Posted: 26.09.2012, 17:55
by iamwudu
In XE 600 (and since 597 I think), FreeCommander freezes when started for about 1 minute.
I'm using Windows 7 SP1.

Here's a pic:
Image

Re: FreeCommander XE 600 freezes at start

Posted: 26.09.2012, 18:12
by inglorious
1. close XE
2. rename "SETTINGS" folder
3. restart XE, if issue persists go to menu / tools /settings /network / check "load network in background process ..."

Re: FreeCommander XE 600 freezes at start

Posted: 26.09.2012, 18:41
by Marek
In XE 600 (and since 597 I think), FreeCommander freezes when started for about 1 minute.
I can see from screenshot - you have folder tree and favorite tree.
Could you check if without the trees is the start normal?

Re: FreeCommander XE 600 freezes at start

Posted: 27.09.2012, 11:06
by iamwudu
Ok, problem found:

I have two network folders in my favorite tree. They're only available in my home network. That causes the problem. Unfortunately the "load network in brackground process" option doesn't help.

The favorite folders ware a great option for me to get rid of the network drives, but I understand that they can cause trouble. Is it possible to not check them at start up? I don't think this is necessary. (And when I click on a folder which is not connected and fC freezes, then it's my fault..)

Re: FreeCommander XE 600 freezes at start

Posted: 27.09.2012, 16:53
by inglorious
(And when I click on a folder which is not connected and fC freezes, then it's my fault..)
nope it never shall freeze, a simple message box would be enough.

Re: FreeCommander XE 600 freezes at start

Posted: 27.09.2012, 19:37
by iamwudu
iamwudu wrote:nope it never shall freeze, a simple message box would be enough.
That's of course the best solution.. I'm just used to the freezing, because the Explorer does that too if the network is not available..

Re: FreeCommander XE 600 freezes at start

Posted: 27.09.2012, 20:32
by Marek
I have two network folders in my favorite tree. They're only available in my home network. That causes the problem.
Could you please add the following line
FavoritesTreeExtractedIcons=0
to the [Form] section of the freecommander.ini and test it again?

Re: FreeCommander XE 600 freezes at start

Posted: 27.09.2012, 21:29
by iamwudu
Marek wrote: Could you please add the following line
FavoritesTreeExtractedIcons=0
to the [Form] section of the freecommander.ini and test it again?
The problem only occurs if a favorite folder has an address that is not available in the current network, e.g. "\\192.168.235.64\test" (given that your subnet isn't 192.168.235 of course...)

When I'm not connected to any network, fC starts without problems. In the favorite tree, the network folders have white icons and when I click on them fC immediately shows an error message that it can't find the path.

"FavoritesTreeExtractedIcons=0" does the trick! No freezing at the startup anymore, and the icons are not white but standard folder icons, great! Clicking on the folder causes the freezing followed by an error message that the network path could not be found, then it freezes for another 10 seconds. After that you can continue normally...

I can absolutely live with that! :)

Thanks.

Re: FreeCommander XE 600 freezes at start

Posted: 04.10.2012, 21:34
by Marek
"FavoritesTreeExtractedIcons=0" does the trick! No freezing at the startup anymore,
Could you please check the release 601 with "FavoritesTreeExtractedIcons=1"?

Re: FreeCommander XE 600 freezes at start

Posted: 05.10.2012, 19:14
by iamwudu
Marek wrote:Could you please check the release 601 with "FavoritesTreeExtractedIcons=1"?
Works! Same behavior as the 600 release with "FavoritesTreeExtractedIcons=0". Great!