Very slow startup on disconnected network drives

Discussion and questions - donor version.
Post Reply
Message
Author
Lux44
Posts: 1
Joined: 10.01.2013, 19:38

Very slow startup on disconnected network drives

#1 Post by Lux44 » 10.01.2013, 19:45

First - thanks for a great program!

The slow startup issue affects both 601 and 609 (public previews).
I have a laptop and some network drives mapped for work. At home these become disconnected. When I start FreeCommander Preview at home, it takes over a minute for it to start. Trying to access the drives and waiting till timeout I presume.

Related (and smaller for me) issue.
When I log on again at work, the mapped drives are disconnected.
When I access the drive with FreeCommander Preview, the connection is not re-established.
When I access the drive from Windows Explorer, the connection is re-established (drive reconnected) and can then be accessed with FreeCommander Preview.

Keep up the good work!

zzzz123
Posts: 15
Joined: 15.10.2013, 08:47

Re: Very slow startup on disconnected network drives

#2 Post by zzzz123 » 16.04.2014, 06:26

I have the same problem. With mapped network drives, startup time of FreeCommander extends up to one minute, regardless of its network settings (for example "Load network in background process on program start".

Could somebody please help and fix this issue or provide a setting which disables network searches in FreeCommander totally - provide setting for some kind of "local only" mode?

PointOtto
Posts: 1
Joined: 04.09.2018, 20:52

Re: Very slow startup on disconnected network drives

#3 Post by PointOtto » 04.09.2018, 20:55

Any news on this item?
The problem is still there.... and it creates me a lot of problem....
there should be a timeout, not more than 10 scond to check if network drive is present!!!


DrNefario
Posts: 2
Joined: 08.04.2020, 00:26

Re: Very slow startup on disconnected network drives

#5 Post by DrNefario » 11.08.2020, 13:31

This problem still exists and seems worse with Windows 2004. I find that it hangs if the network drive is not there. I have waited 5 minutes and had to use task manager to close the program. It is especially bad if the app was closed with the network drive in one panel and it is set to remember the last session. I have tried using both Windows and FreeCommander to manage the network in the settings. I don't know any way to start the app until I am at another location that has the network drive present. My network is a small home network and only has less than a dozen devices connected. I am using version 2020.0.0.810.
I would suggest adding a settable timer feature to avoid this situation. Great program otherwise. Thank you!

User avatar
Dreamer
Site Admin
Posts: 4110
Joined: 19.08.2007, 21:40

Re: Very slow startup on disconnected network drives

#6 Post by Dreamer » 11.08.2020, 18:10

Do you have a problem with both options from the FAQ tip - Use Windows, Use FC? What about the option "Load network in background..."?

Are you using latest FC version? If not, try to upgrade.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 17 guests