Page 1 of 1

Colour scheme in viewer and quick viewer

Posted: 01.05.2019, 00:39
by Alf
Hi there!

‘FreeCommander XE 2019 release 797 donor’ has a new option: colour scheme is used in viewer and quick viewer.

How can I disable this option?

I have different font/text background colour preferences for the viewer/quick viewer and for the file/folder list. Unfortunately, my colour settings for the viewers do not come into effect in release 797:
— When I open a text file in FreeCommander’s viewer, the colours of font and URLs correspond to my settings, but the background colour does not comply with the preferences, it matches the colour settings for the file/folder list;
— When I open a text file in the quick viewer, I see the same problem with the background colour. The colours of font and URLs are correct until I start scrolling the text or just click somewhere on it, then the font colour changes and becomes like the font colour in file/folder list.

---------------------------------------------------------------------------
FreeCommander XE 2019 Build 797 64-bit donor portable, Windows 8.1 64-bit

Re: Colour scheme in viewer and quick viewer

Posted: 01.05.2019, 08:12
by Marek
Currently the color scheme is not used in viewer (quick viewer) for the following color scheme names:
MyDefaultColorSchema
WhiteDefault
White_Default

The freecommander.ini option "ViewerUseColorScheme=0" is implemented for the next release.

Re: Colour scheme in viewer and quick viewer

Posted: 03.05.2019, 10:39
by Alf
Marek wrote:
01.05.2019, 08:12
Currently the color scheme is not used in viewer (quick viewer) for the following color scheme names:
MyDefaultColorSchema...
Nevertheless, I see the opposite: I only use ‘MyDefaultColorSchema’ and, unfortunately, its preference for the background colour interferes with the settings of the viewer and quick viewer. So, I had to roll back to Build 796.

********************
UPD 2019-05-04

With release 798, the viewer follows its settings.
Thank you very much!