Page 1 of 1

822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 08:27
by dsperber
I'm not sure whether this is related to the fact that my display is 4K, with text size scaling set at 250%. This is the Windows default for my new Lenovo P73 laptop with 4K screen, exactly as it came up. I didn't change it. Running Win10 1909.

NVidia T2000 graphics, latest nVidia driver 451.48.
Program object for FCXE -> Properties -> Compatibility tab -> (a) run this program as an administrator, also (b) change high DPI settings -> override high DPI scaling behavior -> Scaling performed by application (in order to eliminate "blurry fonts").

I've never seen this symptom before, but then I've never had a 4K screen (3840x2160) and never had scaling as large as 250%. I normally have my 4K Eizo monitor running at 2560x1440 and with a text size scaling factor of 125%. I normally run my 1080 Eizo monitors running at 1920x1200 with a scaling factor of 125%.

There is something unexpected and odd about how FCXE 8221 (hit is the bug-fix version for the repeated F10 right-creeping divider in lower panel) is painting of the Menu bar which I attribute to the 250% scaling factor. I've tried version 819 on this same Win10 machine, but the symptom is identical. So it's not 819 or 8221, but something in common that is responsible. I assume it's the 4K resolution and 250% scaling, perhaps coupled with "compatibility mode" to override high DPI resolution to let the application program do the scaling.

Here is what File Explorer looks like. Note that P, Q and U are "mapped network drives" from the P73 machine to the DFW machine drives C, D and H.


Here is what FCXE 8221 looks like on this P73 machine. Note the extraordinary amount of space between the items (File, Edit, Folder, etc.) shown on the Menu bar. Also note that none of the three mapped network drives P, Q and U are shown.


Just for comparison, here is how 8221 looks on my DFW machine, which is Win7 and the screen is 1920x1200 at 125%. Note that as expected, all mapped network drives (P, Q, R, etc.) display perfect. Also note the normal amount of space between items on the Menu bar. All this is perfectly normal. But it doesn't look this way on my P73 4K/250% screen.


I am speculating that perhaps the height of the drives button bar is insufficient to draw the icons for the mapped network drives at 250% scaling, which appear to be just slightly taller than the height of the normal local drive icons. Perhaps Windows/graphics or FCXE is simply not presenting it because it won't fit, vertically, in the height available for presentation. I've seen text similarly fail to display in title bars when too large (e.g. 125% improperly handled by application program when drawing the title bar), so maybe the same thing is happening here in the drive button bar of FCXE. I don't see where there is a setting to increase the height of this drive button bar (as there is to increase the height of the address bar), but maybe that's what's needed.

Anybody else run a 4K screen at 250%? Do mapped network drives display for you, or not?

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 09:20
by Dreamer
It's not a solution to your problem, but why are you using small icons? Big icons and size scaling perhaps 200% would look better, its possible to set big icons almost anywhere in FC. You can also set font size larger and it would be probably better too. With size scaling 200% it would be possible also less problems in FC and other programs.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 11:22
by dsperber
I'm not sure I follow your references. Are you talking about "small icons" in Windows -> View -> Small icons? That actually isn't what it is set at. It is "medium icons". And I didn't change that. It was the default value (along with 250% scaling) set by Windows as out-of-the-box. This is the first 4K setup I've worked with, so I just let it remain that way as it actually looked very readable.

As I mentioned previously, on my own 31" Eizo 4K screen I don't run 4K resolution but instead have opted for 2560x1440 and 125% with View -> "small icons". With 2560x1440 on my 31" screen it looks perfect. And in fact I've got this same Eizo screen plugged into the P73 as an external monitor (running in clone-mode, i.e. 1|2 for Windows) and let the resolution remain at 4K/250% so that I could get used to it. It actually looks very much the same as 2560x1440/125% so I left it that way. After I get things built out I intend to explore playing 4K/HDR videos etc., which is why I want to leave the resolutions at native 4K (for both laptop screen and external Eizo).

Anyway, Windows desktop icons are actually "medium".

As far as font scaling of 250%, you're absolutely correct. I've run into several programs (and seemingly, also FCXE) which are affected by the very large scaling and present some output in what is clearly an unexpectedly tiny presentation due to the 4K resolution of the desktop. In other words an output window lookes like a postage stamp on the screen, instead of the normal sized regular window.

But again, I've never actually run my Eizo 4K screen in true 4K. So I wanted to get a feel for how things run at true 4K, given that I paid extra money for the 4K screen on my P73. I do not deny that no doubt I would have ZERO problems if I ran at 2560x1440/125% and small icons, same as I run my desktop machine. For the time being I'm just living with the occasional "defective" output. No question there is also some text that displays incorrectly from assorted programs. I will also experiment using compatibility mode to see if it helps or makes no difference.

Nevertheless, I still feel FCXE is at fault here, failing to display the drive icons on the drive button bar for mapped network drives.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 13:13
by dsperber
Well, now I'm even more baffled.

I was having a problem entering the license key for Adobe Photoshop CS3, because the data entry screen was "miniaturized" (as I described earlier, that some output appears). So temporarily I went back to 2560x1440. Windows changed scaling to 150%. I was now able to enter the PS license key.

While I was at that resolution I decided to retry FCXE, to see if the mapped network drives would now appear. Well, they didn't!

I then change the scaling from 150% to 125%, which is exactly the same as I used in my Win7/Win10 dual-boot desktops which use this same Eizo 4K monitor. I really did expect the mapped network drives to now appear. Well, they still didn't!!!

So now I'm baffled. I have three other Win10 laptops with 1920x180 FHD screens, and mapped network drives appear normally on FCXE (any version). And my Win7/Win10 desktop where the 4K Eizo monitor (running at 2560x1440) also shows mapped network drives on FCXE (any version). I have no idea what's different about this new Win10 P73 laptop with its 4K screen, that causes FCXE to suppress display of the mapped network drive buttons.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 15:24
by Dreamer
My suggestion was to try 200%, if it would be usable for you, and you can increase the font size in FC, with 200% everything should look better than with 250% and perhaps less problems in FC and other programs.

Regarding the icons, I meant icons in FC - and also try the flat icons, they are larger, even standard/small icons, but with option "big icons" the icons look better.

Of course, all these are just my suggestions, not a solution to bug/issue, perhaps Marek will be able to fix it.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 15:35
by dsperber
Ok. Now I'm even more perplexed.

I was fooling around with Netflix app (downloaded from the MS store) to see if 4K videos would be presented. Doesn't seem that way. I also tried with Hulu, and still just "high quality". And in setting things up I also decided to temporarily change my desktop resolution from 3840x2160 to 2560x1440, and also play with the zoom percentage. Tried 150%, 125%, 175%, etc. Went back to 3840x2160 (which pushed zoom back to 250%) and tried 200%, back to 250%, etc.

After opening various programs at each resolution/zoom, eventually I'm back to where I started. 3840x2160 and 250%.

And guess what...


That's right! The three mapped network drives now appear in the drive button bar! I don't know what really caused this to fix itself, but it obviously likely had something to do with the numerous additional programs I installed since originally starting this thread, and/or fooling around with desktop resolution and zoom factor. I'm quite sure that right up until before I installed Hulu and Netflix apps from the MS store I still was missing the mapped network drive buttons. But I can't be sure they hadn't already reappeared for other reasons.

So now I can't explain it. But they do seem to have magically appeared... even with the original 3840x2160 and 250%.

I guess case closed, inexplicably I'm afraid.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 15:54
by dsperber

I've had to re-boot several times since my previous post which showed the unexpected appearance of the mapped network drives. I just now happened to open FCXE for whatever reason, and guess what: THE MAPPED NETWORK DRIVES HAVE DISAPPEARED AGAIN!!!


Obviously the re-boots erased whatever had happened during my multiple changes of desktop resolution/zoom while experimenting with Netflix and Hulu, and things have now returned to "clean" 3840x2160 and 250%. So the conditions which are responsible for the original absence of this drive buttons are back.

Clearly tied to desktop resolution/zoom.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 28.06.2020, 17:06
by Dreamer
Just a suggestion, try to set big icons for toolbars, or/and flat icons option, restart needed - and perhaps change it back - or disable/enable drives bar.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 29.06.2020, 00:52
by dsperber
No breakthrough yet. I did try disabling and then enabling the drive button bar, but no effect. I honestly don't like the larger icons. I've been using the small icons forever and am used to them.

However on a related issue, I've decided not to stay with the 3840x2160 resolution with 250% scaling or any other smaller value. Turns out there are simply too many apps which fail to present their output correctly, or still produce a GUI non-text object output (e.g. Winamp player, Jaangle music organizer, etc.) which simply is unusable at 4K resolution. It's a tiny postage stamp, instead of magnifying the GUI objects up 250% like text. Simply too small and unacceptable when left unmagnifiied. Just unusable.

I revised my two dislplays (4K laptop screen and external 4K Eizo) to run in extended mode rather than duplicate/clone mode which is how I've tried running for a few days now, since both displays were 4K. Instead I tried assorted combinations of independent resolutions and zoom values for each monitor separately, but in the end came back to my old standby of 1920x1080 and 125% for laptop screen, and 2560x1440 and 125% for Eizo. This is the same way I've run my P70 f(FHD laptop screen) for the past four years, and it's perfect.

Of course this means I'm not using the laptop 4K screen which I paid for, but it can always be changed on-demand if there's some reason for it. However for everyday use a 17" screen running at 4K resolution simply is too tiny without a large zoom for text, which induces anomalies with graphic objects.

Regardless.. I still don't have mapped network drives in FCXE.

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 29.06.2020, 06:24
by Karol
The mapped network drives are user specific.
If you have made the mapping with another user, the drives will not be visible.
It is dangerous to run a program as an Admin!

Re: 822/819: 4K screen (250%) Mapped network drives not showing

Posted: 29.06.2020, 18:37
by dsperber
Karol wrote:
29.06.2020, 06:24
The mapped network drives are user specific.
If you have made the mapping with another user, the drives will not be visible.
It is dangerous to run a program as an Admin!
You sir, are a gentleman and a scholar!!

Sure enough when I un-checked "run as administrator" for the FCXE program object, like magic the mapped network drives reappeared on the button bar. And as your predicted, they had been mapped when running with the one-and-only normal user on the machine, who is of course also running with "Administrator" authority.


NOTE: above screenshot taken from the P73 laptop screen, now set to 1920x1080 125%. Note the reduced space between items on the Menu bar from when the laptop was running at 3840x2160 250%. Also smaller and crisper looking character text and other objects. Much nicer overall.

Now I do appreciate your comment that it is "dangerous" to run a program as an Admin. But of course the one-and-only user of a machine is also the conceptual "Administrator" and for all intents and purposes has administrator authority. The problem is that while when using File Explorer and manipulating things in the \Windows folder (e.g. adding a WAV file to \Media) you will get a popup that says "you need administrator authority" to which you reply IGNORE and it proceeds, the same doesn't happen with FCXE (although my example may need refinement). Instead you get "access denied" and there's no way around it, other than to be running FCXE with the "run as administrator" box checked.

During my build-out of this new P73 laptop, I'm doing lots of copying from other machines to this one (e.g. to \ProgramData, or \Users\<userid>\Appdata\Local or \Roaming, or \Documents, etc.) and want to use FCXE to do this. Often I also use Beyond Compare to accomplish the correct copies from one PC to another, and the same story exists about avoiding the authority issues by running the program "as administrator". Of course I'm adept after decades of use of both programs so there's no real concern about mis-use or accidental damage.

Interestingly, now that you've reminded me of it this very same issue came up last year when I had checked Beyond Compare to "run as administrator" specifically to get around these very issues. And I had also noticed that the "mapped network drives" had disappeared. I corresponded with the software author, and he analyzed it as "that's the way it should work" exactly as you've now done for me.

Here is his response to me:


This is expected behavior, it's due to User Account Control (UAC) in
Windows 10.

Drives mapped in standard user context can't be seen by programs running
as administrator and vice versa. If you open a command prompt using Run
As Administrator it also won't be able to see the drives mapped in
standard user context. There are two workarounds:

1. Map the drives a second time as administrator.

2. Set EnableLinkedConnections in the Windows registry to allow standard
user drive mappings to be accessed by programs running as administrator.

EnableLinkedConnections is described in the following Microsoft support
article: ... -uac-is-co


Many many thanks for your advice. My error.

Case closed. Mapped network drive buttons have reappeared.

I will still "run as administrator" when I need to, for both programs, in order to conveniently accomplish the copies I want to using both programs. And I will also update the Registry to set Enable LinkedConnectsion as MS describes, just as an easier solution to avoid mapping all my network drives a second time as Administrator (which I am not normally logged in as).

Otherwise, I will un-check "run as administrator"