832 - Viewer - Ignore Files - 2 minor issues

Bugs and issues - current donor version.
Post Reply
Message
Author
Greenfraggle
Posts: 4
Joined: 20.06.2018, 06:49

832 - Viewer - Ignore Files - 2 minor issues

#1 Post by Greenfraggle » 26.11.2020, 13:11

Updated from Build 822 (where Ignore was working) to Build 832
After update Viewer was now showing the machine code of .zip and .exe files that I had previously set to show nothing in the viewer.

Found changed in Build 826 to now be 'Ignore files - filter list:' this no longer had my settings.
Issue #1: Changing this field then hitting OK, Apply, Ok, Tools, Save Settings does NOT update FreeCommander.ini Closing and re-opening FreeCommander shows field unchanged. Currently have to manually update the .ini file.

Opened FreeCommander.ini
My previous manually set ExtListIgnore=.zip.7z.mdb.ldb.pff.exe.gif.com was still there, but must no longer do anything.
Found new IgnoreFilterList=~$*.doc... option.

Tried: IgnoreFilterList=.zip.7z.mdb.ldb.pff.exe.gif.com
IgnoreFilterList=~$*.zip;~$*.7z;~$*.mdb;~$*.ldb;~$*.pff;~$*.exe;~$*.gif;~$*.com;
Neither worked.

Setting IgnoreFilterList=*.zip;*.7z;*.mdb;*.ldb;*.pff;*.exe;*.gif;*.com; worked

Issue #2: Change Example: ~$*.doc;~$*.docx;
to: Example: *.doc;*.docx;
on the Settings - Viewer - Configure Viewer screen to avoid confusion.


Thanks,

Marek
Author
Author
Posts: 2986
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: 832 - Viewer - Ignore Files - 2 minor issues

#2 Post by Marek » 26.11.2020, 20:08

Issue #2: Change Example: ~$*.doc;~$*.docx;
to: Example: *.doc;*.docx;
on the Settings - Viewer - Configure Viewer screen to avoid confusion.
It is not the issue, it is correctly.
If you open doc, docx file with Winword the temp file will be created. The name of the file started with ~$.
The example shows how to exclude the Winword temp files.
If you use *.doc;*.docx then you can never see the "normal" doc, docx files in viewer.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests