595 Can't drag from left panel [SOLVED]

Bugs and issues - current donor version.
Post Reply
Message
Author
Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

595 Can't drag from left panel [SOLVED]

#1 Post by Scott_Y » 23.06.2012, 15:11

In both 594 and 595, I can both left-drag and right-drag items from the RIGHT panel to the left. But I can't do either from the LEFT panel to the right. This happens irrespective of the NC-mode select setting.

FC-XE 595, Win7 x64
Last edited by Scott_Y on 10.01.2013, 21:14, edited 4 times in total.

User avatar
BGM
Posts: 575
Joined: 14.10.2008, 21:42
Location: Kansas City, Missouri, USA

Re: 595 Can't drag from left panel

#2 Post by BGM » 23.06.2012, 15:53

Scott - I had this problem too - then I noticed I was trying to drag a file into a zip-folder open in the folder pane. I didn't realize it wasn't a folder, and so I got FC's "Pack Archive" popup instead of a context menu.
(Windows 7 Professional 64bit)

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel

#3 Post by Scott_Y » 23.06.2012, 16:00

Thanks, BGM. In my case, I'm trying to drag into a normal folder. Strange that the problem affects the left panel only.

User avatar
BGM
Posts: 575
Joined: 14.10.2008, 21:42
Location: Kansas City, Missouri, USA

Re: 595 Can't drag from left panel

#4 Post by BGM » 23.06.2012, 16:10

Another thought - are you using multiple monitors? I am running with three monitors now, and I noticed that I cannot rearrange icons on my beloved jetToolbar if it is on a particular monitor - but it works just fine on the other two. I have the one monitor using the internal graphics card, and the other two work off of an added pcie graphics card. Strange, but it happens that way. Maybe try your FC on another monitor.

Another idea might be to make sure your graphics card software is updated. That will, indeed, cause issues with drag-and-drop.

Another thing that I learned on my old computer, whose graphics card only had 256mb, is that if I ran Photoshop and Illustrator at the same time, lots of things would no longer work - context menus in particular - it turns out there was not enough GPU (not CPU) memory.
(Windows 7 Professional 64bit)

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel

#5 Post by Scott_Y » 23.06.2012, 17:42

Thanks, BGM. Those are all good suggestions, but I'm using only a single monitor, and the graphics is all up to date.

Note: I have now tested this on releases 591, 593, 594, and 595 -- drag from the left panel does not work in any of them. So I don't know if the problem began on or before 591, or if something is wrong on my system.

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: 595 Can't drag from left panel

#6 Post by joby_toss » 23.06.2012, 17:49

Does it also happen with a fresh copy of FCXE (or new .ini, at least)? It works fine for me...

User avatar
BGM
Posts: 575
Joined: 14.10.2008, 21:42
Location: Kansas City, Missouri, USA

Re: 595 Can't drag from left panel

#7 Post by BGM » 23.06.2012, 19:35

Joby has a good idea. Try it with a fresh ini file. Maybe some combination of options is causing the issue.
(Windows 7 Professional 64bit)

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel

#8 Post by Scott_Y » 23.06.2012, 20:43

Thanks! I deleted FreeCommander.ini, then restarted the program. Problem fixed! Now I get to redo all my settings, and mabye discover some new things in the process.

Edit: Better solution = use a backup version of the ini file. Now I don't have to redo all my customized settings :^)

User avatar
BGM
Posts: 575
Joined: 14.10.2008, 21:42
Location: Kansas City, Missouri, USA

Re: 595 Can't drag from left panel

#9 Post by BGM » 23.06.2012, 20:59

If you go through them one by one, maybe you can figure out the culprit so it can be fixed... (that's painful, however!)
(Windows 7 Professional 64bit)

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel

#10 Post by Scott_Y » 23.06.2012, 21:03

I did a quick file-to-file comparison of the functional backup ini file and the broken ini. I didn't spot anything significant (primarily changes in the tabs, history, filters, etc.).

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel [SOLVED]

#11 Post by Scott_Y » 09.01.2013, 21:59

I'm still having this problem in 611 and a number of previous builds. I can't drag anything from the left pane, whether to the right pane or to another program. I can only drag from the right pane.

I solved this previously by deleting FreeCommander.ini, but I don't want to have to redo my settings every time this problem develops. Is anybody else having this problem?

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 595 Can't drag from left panel [SOLVED]

#12 Post by Marek » 09.01.2013, 22:03

Could you send me all your config files?

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel [SOLVED]

#13 Post by Scott_Y » 09.01.2013, 22:15

Thanks, Marek. I'll send them by email attachment.

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 595 Can't drag from left panel

#14 Post by Marek » 10.01.2013, 20:30

Thanks for the files, unfortunatelly I have no problems with drag&drop with your settings (from left and right panel).
You know, for drag beginn you must click on icon or file name.

Scott_Y
Posts: 504
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: 595 Can't drag from left panel

#15 Post by Scott_Y » 10.01.2013, 21:13

Thanks, you've pointed me to the source of my problem!

For the right panel, it is easy for me to click directly on an object's name. But for the left panel, I tend to click to the right side of a name so as to avoid long mouse travel on a notebook touchpad. I thought if I clicked anywhere in the Name column, it should be enough to grab the object. But as you say, I must click ON the name or icon. Actually there is a small distance to the right of a name that is allowed as well, but I have been clicking outside even that. So the cause of the problem was awkward mouse-travel ergonomics.

EDIT: This "problem" may have started when I bought a new notebook computer with a wider screen than my old one, hence more distance for the mouse to reach objects in the left panel.

Post Reply

Who is online

Users browsing this forum: No registered users and 123 guests