Page 1 of 1

600 - folder doesn't exist bug

Posted: 24.09.2012, 19:30
by inglorious
to repro

- navigate to C:
- open some C: tabs
- MMB to select address field, while selected
- Menu Folder / Go to folder ... Button, Select "Desktop"

-> Error: folder doesn't exist
-> now close C: tabs via MMB: CRASH!

FYI, Bug is not present in FC2009

Re: 600 - folder doesn't exist bug

Posted: 24.09.2012, 20:21
by Marek
-> Error: folder doesn't exist
Fixed for the release 601.
-> now close C: tabs via MMB: CRASH!
I can not reproduce it.

Re: 600 - folder doesn't exist bug

Posted: 24.09.2012, 20:30
by Dreamer
Can't confirm the crash on Vista 32 bit.

Re: 600 - folder doesn't exist bug

Posted: 25.09.2012, 17:45
by inglorious
just figured out how to reproduce the crash, seems to be another issue, still don't take it amiss if
I post here steps to repro it:

first make sure to create many (a lot) of new tabs, then MMB to close each tab,
now as the tab view is not refreshed correctly, XE tries to close an inexistent tab, thus the crash:
Image

Re: 600 - folder doesn't exist bug

Posted: 25.09.2012, 19:05
by Marek
Could you send me the bug report and your freecommander.ini?

Re: 600 - folder doesn't exist bug

Posted: 26.09.2012, 18:06
by inglorious
bugreport pmed. crash reproducible with clean/resetted XE 600:
Image

Re: 600 - folder doesn't exist bug

Posted: 26.09.2012, 19:21
by Marek
It works fine for me.
The reported bug is in the external library I use for tabs. After 601 release I will update the library to the new version and then we should check it again.