Slow copy/paste on Win7 (FC hooking to something)

Bugs and issues - current donor version.
Post Reply
Message
Author
kino
Posts: 53
Joined: 01.04.2013, 21:24

Slow copy/paste on Win7 (FC hooking to something)

#1 Post by kino » 09.02.2015, 09:57

Hi,
I'm having a "slow" issue on copying/moving on Windows 7 32b Ultimate (not on 64b at work) with FC tested up to beta 682.
Something in FC looks like hooking to some event of some sort because it hangs for a while (sometime as long as 30s) before giving back control.
The action, though, is effective immediately and I can see it while opening Windows explorer (I can actually open the moved/copied file way before control is given back in FC).
Also, it doesn't happen with the native Windows explorer but still happens when configuring FC to use Windows for moving/copying.
Do you know what FC could be waiting for ? (or what Windows might make it wait for)
I've tried digging the stack of several threads in procexp but it's pretty unintelligible to me.
Thanks

kino
Posts: 53
Joined: 01.04.2013, 21:24

Re: Slow copy/paste on Win7 (FC hooking to something)

#2 Post by kino » 23.02.2015, 14:20

My problem seems to have little to do with FC although it doesn't happen with the common Windows file explorer.
Sysinternals Procmon revealed massive access to Recycle Bin whatever I was doing (copying, moving and of course deleting) ; weird ; Win wizs would probably understand why.
Emptying trash can solved it.

kino
Posts: 53
Joined: 01.04.2013, 21:24

Re: Slow copy/paste on Win7 (FC hooking to something -> anti-virus)

#3 Post by kino » 02.11.2017, 10:47

Hello,

I've made some significant progress investigating that recurrent problem : it now is obvious to me that it relates to anti-virus software and some post-op hook (like post create, delete, copy files) that anti-virus subscribed to the os.

Facts :

- It happens with AVG as well as Avast (separately, needless to say : I only have one anti-virus installed at a time)
- I can spot some antivirus post-activity within procmon.exe (from Sysinternals) without it being clear about what is done
- It does *NOT* happen when I create/delete/copy through the native windows file explorer
- I ceases to happen when I totally uninstall AVG or Avast
- Nonetheless it still happens when I only desactivate AVG or Avast agent (I actually doubt those programs do completely shut down since some activity is seen post-ops and their main service is locked against shutdown)

Questions :

- have anyone experienced those unbearable latencies with FreeCommander operations ? (I'm talking about 10 secs sometimes !)
- why with FreeCommander and not Windows Exporer ?
- any way to unhook FC ops from anti-virus ?

Thanks

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 5 guests