R740 Command line option /Panel=R fails

Bugs and issues - current donor version.
Post Reply
Message
Author
Zorkoff
Posts: 106
Joined: 10.05.2011, 21:14
Location: Boston, MA

R740 Command line option /Panel=R fails

#1 Post by Zorkoff » 22.01.2017, 22:08

R740 Command line option /Panel=R fails under certain conditions

Here are the steps needed to reproduce this problem:

Start FCXE 740 with the command line: FreeCommander.exe /ini=test.ini /panel=R
-- where test.ini does not exist (a default file is created)

Initially this results in the Right panel becoming active (the default is the Left panel).


Go into the Options View > Tree > General Tab > Set one tree per panel

Go into the Options View > Tree > Management tab > Set Base folder to Drive

Apply both settings. and exit the options window.


Now in the main display enable the tree display in the Left panel and select Drive C:

In the right panel select another hard drive (Like D: - not the desktop (0) icon)

Exit FreeCommander and start again with the same command line shown above.

Now the active panel is the Left panel. So the option /Panel=R has no effect.


Also, with the same settings, changing the right panel drive to the Desktop Drive Icon (0) and Exiting/Restarting FreeCommander will result in the right panel being active.


I had to do some investigation to find, what I believe is, the minimum changes to cause this to happen. I normally run FXCE with the options above and display a tree in each panel. I have 9 HDD partitions (Drives), 4 flash drives and one Optical drive. The new /Panel=R option has never worked for me since it was implemented. I hope this description will help to uncover what is causing this problem so I can use this feature.

Marek
Author
Author
Posts: 2495
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: R740 Command line option /Panel=R fails

#2 Post by Marek » 04.02.2017, 18:25

Please check it in the release 741.

Zorkoff
Posts: 106
Joined: 10.05.2011, 21:14
Location: Boston, MA

Re: R740 Command line option /Panel=R fails

#3 Post by Zorkoff » 04.02.2017, 19:54

Marek, Release 741 seems to have fixed the problem, but with a slightly delayed display.

I tested using both "-Panel=R" and "/Panel=R" command line arguments for both the 32-bit and 64-bit portable versions and the results were the same.

When FreeCommanderXE opens the Tree and File lists in each panel, the Left Panel is active for almost 1 second and then the active panel switches to the Right Panel. I don't understand the 1 second delay, but it is weird at best.

I have a very fast computer (i7-6700K and Z170 chipset with a SSD for C:) so the delay is strange.

But thank you for for the fast fix.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests