770 display issues [edit: version number now correct]

Bugs and issues - current donor version.
Post Reply
Message
Author
alf5000
Posts: 425
Joined: 12.04.2012, 15:59
Location: Austria

770 display issues [edit: version number now correct]

#1 Post by alf5000 » 24.01.2018, 19:40

I change 3 settings in Details list (Ctrl+F2) and get this behavior:

Image


1) switch to detail list view
2) untick 'Use Windows colors' (you might ask why I would want to do this. well, if I want to use NC-Mode I must untick this to get reasonable results)
3) untick 'Border only' at Focused item active list
4) set background color of Focused item active list to white

Image

this is pretty much related to that topic, but I guess that one got partially fixed and is a bit hard to follow for new guests:
http://forum.freecommander.com/viewtopic.php?f=7&t=8338
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2207
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 770 display issues [edit: version number now correct]

#2 Post by Marek » 04.02.2018, 15:50

It is probably some display problem on Windows 7 only.
On Windows 10 all is clean.

alf5000
Posts: 425
Joined: 12.04.2012, 15:59
Location: Austria

Re: 770 display issues [edit: version number now correct]

#3 Post by alf5000 » 04.02.2018, 17:31

Win10 acts differently, indeed - but not correctly.

1) win10, totally fresh fcxe_770
2) just untick 'Use windows colors' (don't untick Only borders)
3) click OK and everythings seems good
4) now focus another file in the file list (I just used the arrow button) --> colors are not as expected


NC-Mode colors are perfect on win10 and pretty much usable on win7.
I wanted to point out that the name column lacks that dotted border-line whereas all the other columns show a dotted border-line
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2207
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 770 display issues [edit: version number now correct]

#4 Post by Marek » 04.02.2018, 19:11

If you start with fresh ini - than you mean default selection mode (as Windows Explorer).
If you have used in 4) arrow "down" or "up" than you have not focused other item but selected.
You must use Ctrl+Up or Ctrl+Down if you want to see focused item.
For me it is all ok.

alf5000
Posts: 425
Joined: 12.04.2012, 15:59
Location: Austria

Re: 770 display issues [edit: version number now correct]

#5 Post by alf5000 » 04.02.2018, 20:46

thanks, for working on it :P

yes, you're correct: it's default selection mode (Windows mode)
(I prefer NC-mode but some versions ago there were changes in FCXE color handling and I had to find a solution and found some issues)

here my results from win10
watch the settings (background and border settings) carefully
Image

result1: active list one file selected AND focused (for me it's strange, why blue and red mix?)
Image

result2: active list multiple files selected (for me that's super strange, but it clearly shows that the name column is handled somehow differently. I suppose this difference in handling is also responsible for Win7 dotted-border issue)
Image

of course I'd never use these color combinations, but they best show the inconsistency.
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2207
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 770 display issues [edit: version number now correct]

#6 Post by Marek » 04.02.2018, 21:22

result1: active list one file selected AND focused (for me it's strange, why blue and red mix?)
Its not strange, you have defined such colors.
Try now with Ctrl+Up or Ctrl+Down move the focused item. You can see the red rectangle for focused item and the selected item have now color defined for selected items.
The border of the focused item has higher priority.
result2: active list multiple files selected (for me that's super strange, but it clearly shows that the name column is handled somehow differently. I suppose this difference in handling is also responsible for Win7 dotted-border issue)
The colors are ok. I think the vertical line after name column should be checked.

alf5000
Posts: 425
Joined: 12.04.2012, 15:59
Location: Austria

Re: 770 display issues [edit: version number now correct]

#7 Post by alf5000 » 05.02.2018, 11:27

oh, my goodness!
now it's clear, @Karol taught me in another thread (http://forum.freecommander.com/viewtopi ... 459#p27070) that there is a color priority thing going on I was not aware of! :idea:

yes, the vertical line should be checked.

yes, and the dotted line issue in Win7 needs a closer look, IMO. - why is name column treated differently?
win7pro x64 - FCXE x64

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest