800 - Switching view modes issues

Bugs and issues - current donor version.
Post Reply
Message
Author
User avatar
Dreamer
Site Admin
Posts: 3844
Joined: 19.08.2007, 21:40

800 - Switching view modes issues

#1 Post by Dreamer » 14.07.2019, 12:11

To reproduce:
- use default settings, probably not needed
- change view to "large icons" (using main menu or context menu)
= icon for list view is active in toolbar
- now click the list view toolbar icon to switch to list view
= it doesn't work (menu option works)

It's the same with "small icons" instead of "large icons".

FC 800 donor 64-bit, Win 10 64-bit 1809.

horst.epp
Posts: 161
Joined: 15.11.2008, 19:18

Re: 800 - Switching view modes issues

#2 Post by horst.epp » 14.07.2019, 12:21

Not fully confirmed here.
Swiching the view using the toolbar icons works most of the times.
But I could reproduce the problem sometimes.
FC 800 donor 64-bit, Win 10 64-bit 1903.
Windows 10 Home x64 November 2019 Update, Version 1909 (OS Build 18363.815)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
Total Commander 9.51 x64 / x86, Everything 1.4.1.978 (x64)
FreeCommander XE 2020 Build 818 64-bit donor

User avatar
Dreamer
Site Admin
Posts: 3844
Joined: 19.08.2007, 21:40

Re: 800 - Switching view modes issues

#3 Post by Dreamer » 14.07.2019, 13:29

Really? Even if you switch to "large icons" view from main menu and then click the "list view" toolbar icon? I can always reproduce it this way.

Odamn-Ete
Posts: 81
Joined: 28.06.2017, 05:10

Re: 800 - Switching view modes issues

#4 Post by Odamn-Ete » 15.07.2019, 07:24

cannot confirm,

can switch back and forth no prblem. The only thing I've noticed is when switching to use large or small icons, the last active toolbar button (List view, Details view, etc.) remains active in the toolbar. Don't know if thats normal behaviour.

FreeCommander XE 2018 Build 800 64-bit donor
Windows 10 Pro 64-bit Version 1809 Build 17763.615

User avatar
Dreamer
Site Admin
Posts: 3844
Joined: 19.08.2007, 21:40

Re: 800 - Switching view modes issues

#5 Post by Dreamer » 15.07.2019, 15:50

That's it, that's the bug.

To reproduce, use "large icons" option, from main menu, then use "list" view toolbar button - that one which is active, just click it.

It should switch to "list" view, but it doesn't work.

Odamn-Ete
Posts: 81
Joined: 28.06.2017, 05:10

Re: 800 - Switching view modes issues

#6 Post by Odamn-Ete » 16.07.2019, 05:47

okay, can confirm.

it doesn't matter if you start in list view, detail view or another view, if after using the menu to change to use large icons, or to use small icons, the last view toolbar button remains active and clicking on it produces no action, i.e. the view doesn't change accordingly. One can switch to another view by clicking on an inactive toolbar button, then all toolbar buttons work as they are intended to.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests