'Thumbnails view' buggy on highDPI screen

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

'Thumbnails view' buggy on highDPI screen

#1 Post by alf5000 » 13.11.2016, 18:25

just watch the pic (I prefer NC-mode):
Image

1) text is not fully visible (problem does not go away if I increase the distance between the thumbnails)

the following does not depend on screen resolution, but IMHO some improvement is necessary:
2) hard to see: which thumbnail is selected?
3) hard to see: which thumbnail has focus?
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2090
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 'Thumbnails view' buggy on highDPI screen

#2 Post by Marek » 04.12.2016, 21:25

I have made many changes in the 731 for highDPI screens but unfortunately this problem is not fixed yet.
You could try workaround and define smaller font for the thumbnail view:

ThumbnailsViewFontSizeLimit=8

alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

Re: 'Thumbnails view' buggy on highDPI screen

#3 Post by alf5000 » 05.12.2016, 13:27

good to see it's being worked on - I found some more things, perhaps they help you solve the problem.
by the way ThumbnailsViewFontSizeLimit=8 --> good workaround

open the settings dialogue make some minor change to Spacing for example and click Apply. as long as the settings dialog is open it looks like this:
Image

when you close the settings dialog now using X button everything is fine until you change the Tab.
when you close the settings dialog using the OK button everything gets weird at once.
Image
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2090
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 'Thumbnails view' buggy on highDPI screen

#4 Post by Marek » 11.12.2016, 20:01

Great tip - changed for the next release.

alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

Re: 'Thumbnails view' buggy on highDPI screen

#5 Post by alf5000 » 20.12.2016, 19:54

sorry, problem still exists - but some filenames (randomly?) are shown correctly
Image
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2090
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 'Thumbnails view' buggy on highDPI screen

#6 Post by Marek » 20.12.2016, 20:33

What is your screen resolution, Windows version and font setting in Windows, 200%?

alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

Re: 'Thumbnails view' buggy on highDPI screen

#7 Post by alf5000 » 21.12.2016, 10:11

15"-Notebook (Lenovo)
Resolution: 2880x1620 (recommended)
Font setting: 200%
win7pro x64

[edit]
again: everything's ok as long as the Settings-dialog is open.
win7pro x64 - FCXE x64

Marek
Author
Author
Posts: 2090
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 'Thumbnails view' buggy on highDPI screen

#8 Post by Marek » 22.12.2016, 19:49

In the release 734 I have started with thumbnail view drawed by Windows.
You could try it - add the following line in the freecommander.ini in the [Form] section:
ThumbsFCDraw=0

alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

Re: 'Thumbnails view' buggy on highDPI screen

#9 Post by alf5000 » 23.12.2016, 16:57

wow.
everything okay with "ThumbsFCDraw=0" :)

thanks.
win7pro x64 - FCXE x64

alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

Re: 'Thumbnails view' buggy on highDPI screen

#10 Post by alf5000 » 02.01.2017, 21:53

alf5000 wrote:wow.
everything okay with "ThumbsFCDraw=0" :)
thanks.
sorry, not everything is o.k.

after returning from Thumbnails view FCXE forgets the correct font-setting of the panel (the right panel shows correct font: Segoe UI, semibold, 10). restarting FCXE corrects the mistake.
watch the pic, it shows the left and the right panel of ONE and the same instance of FCXE.

Image
win7pro x64 - FCXE x64

alf5000
Posts: 380
Joined: 12.04.2012, 15:59
Location: Austria

Re: 'Thumbnails view' buggy on highDPI screen

#11 Post by alf5000 » 07.01.2017, 18:30

fonts are correct now on 736!
super.
win7pro x64 - FCXE x64

samarra
Posts: 2
Joined: 16.03.2017, 17:56

Re: 'Thumbnails view' buggy on highDPI screen

#12 Post by samarra » 16.03.2017, 18:08

alf5000 wrote:just watch the pic (I prefer NC-directory):
Image

1) text is not fully visible (problem does not go away if I increase the distance between the thumbnails)

the following does not depend on screen resolution, but IMHO some improvement is necessary:
2) hard to see: which thumbnail is selected?
3) hard to see: which thumbnail has focus?
Hi alf5000,

Thank you for posting your case, I got a similar issue. Your post has helped me!

Thanks to forum mates for support!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest