Menu icons disappeared

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Menu icons disappeared

#1 Post by m-a-r-k » 01.03.2019, 17:38

793 and 794
On Windows 7 and Windows 10, using 64-donor-portable versions, I've lost all menu icons.


m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Re: Menu icons disappeared

#3 Post by m-a-r-k » 02.03.2019, 12:35

Yes, obviously that was first port of call and toggling had no effect.
Icons disappeared with v793
ini file shows ShowGlyphsInMenu=1
Same for Windows 7 laptop and Windows 10 PC, icons disappeared at same time after update to 793.

User avatar
Dreamer
Site Admin
Posts: 3324
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: Menu icons disappeared

#4 Post by Dreamer » 02.03.2019, 13:36

Strange, I can't reproduce, try to switch the "flat icons" option, or/and test with default settings, if it will be OK, then it must be some ini issue...

http://forum.freecommander.com/viewtopic.php?f=19&t=17

Or you can try to use some ini from backup, they are creating automatically.

m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Re: Menu icons disappeared

#5 Post by m-a-r-k » 02.03.2019, 18:30

Flat icons is for toolbars, no setting for Main Menu as far as I can see.
Restored 6 generations of backups to no effect.

started FC with parameters: /N /NewIni=%FcAppDataPath%\Settings\FreeCommanderTest.ini /NoPlugins /Lng=English and icons returned.

Removed other settings file, no change.
So something in my ini.
Strange it's on 2 different computers which suggests newly introduced code is conflicting with my particular layout/settings etc. especially as all backups also display no menu icons.

m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Re: Menu icons disappeared

#6 Post by m-a-r-k » 03.03.2019, 14:24

Nailed it down to this line in my ini file

ShowMainToolbarAsOneToolbar=0
under [fcActionToolbars]

Take it out and menu icons reappear!

Going to 'Tools' menu, 'Define Action Toolbars...' 'General options' tab, click on 'Show menu as toolbar' removes menu icons instantly.

User avatar
Dreamer
Site Admin
Posts: 3324
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: Menu icons disappeared

#7 Post by Dreamer » 03.03.2019, 17:55

Thanks for the information, so it was very close to the option I said you could try, right above. :)

I can reproduce it with default settings in 794, it's a bug.

m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Re: 793, 794, 795: Menu icons disappeared

#8 Post by m-a-r-k » 18.03.2019, 19:20

Still present in 795

Marek
Author
Author
Posts: 2475
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: Menu icons disappeared

#9 Post by Marek » 18.03.2019, 20:06

I saw that too late.
Fixed for the next release 797.

m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Re: Menu icons disappeared

#10 Post by m-a-r-k » 19.03.2019, 19:09

Thank you so much Marek

m-a-r-k
Posts: 60
Joined: 03.06.2013, 18:43

Re: Menu icons disappeared

#11 Post by m-a-r-k » 28.04.2019, 16:03

Confirm now fixed in 797
Thank you

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests