Support side mouse buttons for back and forward navigation

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
blackbox
Posts: 12
Joined: 05.10.2008, 17:34

Support side mouse buttons for back and forward navigation

#1 Post by blackbox » 05.10.2008, 18:16

Many mice now feature two additional buttons (X buttons), usually on the left side, that perform back/forward commands.
While mainly labeled by manufacturers as "internet" buttons, they are widely supported in many other applications besides web browsers, e.g.: Windows Explorer, Media Player, Photo Gallery / Picture and Fax Viewer, iTunes, Picasa, Media Player Classic.
Also, in Vista these buttons are supported in all native wizards and common file open/save dialogs.

When I bought my first mouse with X buttons (Logitech MX400), I thought that they are redundant and unnecessary, but after some time I found myself using them more and more. Indeed, it's much faster to press the button on the mouse than to reach and click the the tiny toolbar button.

While many mice come with manufacturer's drivers that install all sorts of crap (Logitech SetPoint :evil:, Logitech Desktop Messenger :evil: etc.), XP and Vista have native support for these buttons in their built-in drivers.

All that is needed to add support for back/forward buttons in the application is to process window message WM_XBUTTONUP:

Code: Select all

	switch (msg) {
	case WM_XBUTTONUP:
		switch (GET_XBUTTON_WPARAM(wParam)) {
		case XBUTTON1:
			GoBack();
			return TRUE;
		case XBUTTON2:
			GoForward();
			return TRUE;
		}
		break;
	}
It would be really great if you add support for X buttons in FreeCommander and built-in file viewer!

Marek
Author
Author
Posts: 2495
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

#2 Post by Marek » 07.10.2008, 19:40

I do not have such mouse :). Send me PM with your email address and I send you a test version.

User avatar
Dreamer
Site Admin
Posts: 3376
Joined: 19.08.2007, 21:40
Location: Slovakia

#3 Post by Dreamer » 12.10.2008, 22:00

Added in the latest beta version. It's working good with my Logitech mouse. Please test your mouse and report the problems in Bug Reports forum.

Closed.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests