[fixed] Creating folders using invalid characters

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
larsen
Posts: 141
Joined: 12.01.2013, 14:12

[fixed] Creating folders using invalid characters

#1 Post by larsen » 05.09.2014, 18:01

Tested with build 671:

- Create a new folder called "2014/2015"
Result: A folder "2015" is created.

- Try to rename the folder "2015"
Result: Error message "The file/folder name is not valid: d:\test\whatever\2014/2015".

Windows Explorer behaviour (Win 7) is to not allow some characters including the slash. Explorer shows the invalid characters in a balloon help. IMHO FC should show the same info.
Last edited by larsen on 12.09.2014, 13:42, edited 2 times in total.

User avatar
Dreamer
Site Admin
Posts: 4029
Joined: 19.08.2007, 21:40

Re: Creating folders using invalid characters

#2 Post by Dreamer » 06.09.2014, 12:15

- Create a new folder called "2014/2015"
Result: A folder "2015" is created.
Confirmed, it's a bug.
- Try to rename the folder "2015"
Result: Error message "The file/folder name is not valid: d:\test\whatever\2014/2015".
Can't confirm.

FYI - FC has a feature, when you type e.g. "2014\2015" in the new folder dialog - folder "2014" is created and another folder "2015" inside that folder, it's useful, backslash is used to create subdirectories, but when using forward slash, it should not be allowed and it's a bug IMO.

FC 671, Win Vista 32 bit.

larsen
Posts: 141
Joined: 12.01.2013, 14:12

Re: Creating folders using invalid characters

#3 Post by larsen » 12.09.2014, 13:41

With FC 672, using a slash leads to a folder and a subfolder being created. Same way what happens when using a backslash.
Not sure if this shouldn´t instead throw a warning like renaming does, but I also guess this could be handy for someone.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests