686 - Browse for folder problem in "Go To Folder" dialog

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
larsen
Posts: 141
Joined: 12.01.2013, 14:12

686 - Browse for folder problem in "Go To Folder" dialog

#1 Post by larsen » 27.02.2015, 14:23

Steps to reproduce:
- Open "Go To Folder" dialog
- Enter some text/path into the text field
- Click on the button to the right to browse for a folder
- Select any folder

Result: The selected folder is appended to the existing text. When you try to open this it will of course fail.

Expected result: Selected folder should replace any text so you don´t have to manually remove the previous text to be able to go to that folder.

Timon
Posts: 708
Joined: 13.09.2012, 06:51

Re: 686 - Browse for folder problem in "Go To Folder" dialog

#2 Post by Timon » 27.02.2015, 18:32

Confirmed in FreeCommander XE 2015 Build 686 32-bit donor

For example, on local disk C we have folder Test, and local disk C is opened in active panel
- Open "Go To Folder" dialog
- Enter "Test" into the text field
- Click on the button to the right to browse for existing folder on any local disk, for example, D:\Install and select it
- in the text field we'll see "Test; D:\Install"
- Press OK button
- We'll see error message Folder doesn't exist: C:\Test; D:\Install (as I understood, disk name from active panel is always added to first partial path)

But I think in such a case "C:\Test" should be opened in active panel and "D:\Install" - in inactive panel. That would be expected result.

larsen
Posts: 141
Joined: 12.01.2013, 14:12

Re: 686 - Browse for folder problem in "Go To Folder" dialog

#3 Post by larsen » 28.02.2015, 10:17

Forgot to mention that: I´m using only one panel with the directory tree on the left. So, there is no inactive panel for me and "go to" should only open the selected folder in that panel.

joby_toss
Posts: 1345
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: 686 - Browse for folder problem in "Go To Folder" dialog

#4 Post by joby_toss » 07.03.2015, 17:14

Fixed in 687. Thank's!

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests