Page 1 of 1

Menu icons disappeared

Posted: 01.03.2019, 17:38
by m-a-r-k
793 and 794
On Windows 7 and Windows 10, using 64-donor-portable versions, I've lost all menu icons.

Re: Menu icons disappeared

Posted: 01.03.2019, 20:08
by Dreamer

Re: Menu icons disappeared

Posted: 02.03.2019, 12:35
by m-a-r-k
Yes, obviously that was first port of call and toggling had no effect.
Icons disappeared with v793
ini file shows ShowGlyphsInMenu=1
Same for Windows 7 laptop and Windows 10 PC, icons disappeared at same time after update to 793.

Re: Menu icons disappeared

Posted: 02.03.2019, 13:36
by Dreamer
Strange, I can't reproduce, try to switch the "flat icons" option, or/and test with default settings, if it will be OK, then it must be some ini issue...

http://forum.freecommander.com/viewtopic.php?f=19&t=17

Or you can try to use some ini from backup, they are creating automatically.

Re: Menu icons disappeared

Posted: 02.03.2019, 18:30
by m-a-r-k
Flat icons is for toolbars, no setting for Main Menu as far as I can see.
Restored 6 generations of backups to no effect.

started FC with parameters: /N /NewIni=%FcAppDataPath%\Settings\FreeCommanderTest.ini /NoPlugins /Lng=English and icons returned.

Removed other settings file, no change.
So something in my ini.
Strange it's on 2 different computers which suggests newly introduced code is conflicting with my particular layout/settings etc. especially as all backups also display no menu icons.

Re: Menu icons disappeared

Posted: 03.03.2019, 14:24
by m-a-r-k
Nailed it down to this line in my ini file

ShowMainToolbarAsOneToolbar=0
under [fcActionToolbars]

Take it out and menu icons reappear!

Going to 'Tools' menu, 'Define Action Toolbars...' 'General options' tab, click on 'Show menu as toolbar' removes menu icons instantly.

Re: Menu icons disappeared

Posted: 03.03.2019, 17:55
by Dreamer
Thanks for the information, so it was very close to the option I said you could try, right above. :)

I can reproduce it with default settings in 794, it's a bug.

Re: 793, 794, 795: Menu icons disappeared

Posted: 18.03.2019, 19:20
by m-a-r-k
Still present in 795

Re: Menu icons disappeared

Posted: 18.03.2019, 20:06
by Marek
I saw that too late.
Fixed for the next release 797.

Re: Menu icons disappeared

Posted: 19.03.2019, 19:09
by m-a-r-k
Thank you so much Marek

Re: Menu icons disappeared

Posted: 28.04.2019, 16:03
by m-a-r-k
Confirm now fixed in 797
Thank you