FreeCommander XE 600 freezes at start

Discussion and questions - donor version.
Post Reply
Message
Author
iamwudu
Posts: 5
Joined: 26.09.2012, 17:38

FreeCommander XE 600 freezes at start

#1 Post by iamwudu » 26.09.2012, 17:55

In XE 600 (and since 597 I think), FreeCommander freezes when started for about 1 minute.
I'm using Windows 7 SP1.

Here's a pic:
Image

inglorious
Posts: 277
Joined: 31.08.2011, 22:10

Re: FreeCommander XE 600 freezes at start

#2 Post by inglorious » 26.09.2012, 18:12

1. close XE
2. rename "SETTINGS" folder
3. restart XE, if issue persists go to menu / tools /settings /network / check "load network in background process ..."
Win7x64

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: FreeCommander XE 600 freezes at start

#3 Post by Marek » 26.09.2012, 18:41

In XE 600 (and since 597 I think), FreeCommander freezes when started for about 1 minute.
I can see from screenshot - you have folder tree and favorite tree.
Could you check if without the trees is the start normal?

iamwudu
Posts: 5
Joined: 26.09.2012, 17:38

Re: FreeCommander XE 600 freezes at start

#4 Post by iamwudu » 27.09.2012, 11:06

Ok, problem found:

I have two network folders in my favorite tree. They're only available in my home network. That causes the problem. Unfortunately the "load network in brackground process" option doesn't help.

The favorite folders ware a great option for me to get rid of the network drives, but I understand that they can cause trouble. Is it possible to not check them at start up? I don't think this is necessary. (And when I click on a folder which is not connected and fC freezes, then it's my fault..)

inglorious
Posts: 277
Joined: 31.08.2011, 22:10

Re: FreeCommander XE 600 freezes at start

#5 Post by inglorious » 27.09.2012, 16:53

(And when I click on a folder which is not connected and fC freezes, then it's my fault..)
nope it never shall freeze, a simple message box would be enough.
Win7x64

iamwudu
Posts: 5
Joined: 26.09.2012, 17:38

Re: FreeCommander XE 600 freezes at start

#6 Post by iamwudu » 27.09.2012, 19:37

iamwudu wrote:nope it never shall freeze, a simple message box would be enough.
That's of course the best solution.. I'm just used to the freezing, because the Explorer does that too if the network is not available..

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: FreeCommander XE 600 freezes at start

#7 Post by Marek » 27.09.2012, 20:32

I have two network folders in my favorite tree. They're only available in my home network. That causes the problem.
Could you please add the following line
FavoritesTreeExtractedIcons=0
to the [Form] section of the freecommander.ini and test it again?

iamwudu
Posts: 5
Joined: 26.09.2012, 17:38

Re: FreeCommander XE 600 freezes at start

#8 Post by iamwudu » 27.09.2012, 21:29

Marek wrote: Could you please add the following line
FavoritesTreeExtractedIcons=0
to the [Form] section of the freecommander.ini and test it again?
The problem only occurs if a favorite folder has an address that is not available in the current network, e.g. "\\192.168.235.64\test" (given that your subnet isn't 192.168.235 of course...)

When I'm not connected to any network, fC starts without problems. In the favorite tree, the network folders have white icons and when I click on them fC immediately shows an error message that it can't find the path.

"FavoritesTreeExtractedIcons=0" does the trick! No freezing at the startup anymore, and the icons are not white but standard folder icons, great! Clicking on the folder causes the freezing followed by an error message that the network path could not be found, then it freezes for another 10 seconds. After that you can continue normally...

I can absolutely live with that! :)

Thanks.

Marek
Author
Author
Posts: 2535
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: FreeCommander XE 600 freezes at start

#9 Post by Marek » 04.10.2012, 21:34

"FavoritesTreeExtractedIcons=0" does the trick! No freezing at the startup anymore,
Could you please check the release 601 with "FavoritesTreeExtractedIcons=1"?

iamwudu
Posts: 5
Joined: 26.09.2012, 17:38

Re: FreeCommander XE 600 freezes at start

#10 Post by iamwudu » 05.10.2012, 19:14

Marek wrote:Could you please check the release 601 with "FavoritesTreeExtractedIcons=1"?
Works! Same behavior as the 600 release with "FavoritesTreeExtractedIcons=0". Great!

Post Reply

Who is online

Users browsing this forum: No registered users and 171 guests