Crash when hiding main menu

Bugs and issues.
Post Reply
Message
Author
ulogic
Posts: 3
Joined: 13.09.2010, 21:27

Crash when hiding main menu

#1 Post by ulogic » 01.03.2014, 23:34

This happened with Free Commander XE build 650 after a fresh installation or after deleting FreeCommander.ini. I added the button to show/hide the main menu at the far left of the standard toolbar. Then when the button is clicked, a crash dialog comes up. I only have web based email so the crash handler was unable to send a dump log.

I was able to reproduce this on one XP machine and two Win7 x64 machines. The problem goes away if you go under Tools, Customize toolbar, General options, then change "Show main toolbar as" from the default of one wrappable toolbar to many toolbars. Even setting the option back to one wrappable toolbar does not cause the crash to occur any more. However, the problem can be reproduced by deleting the INI file and repeating the steps in the first paragraph above.

User avatar
Dreamer
Site Admin
Posts: 3409
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: Crash when hiding main menu

#2 Post by Dreamer » 02.03.2014, 01:15

Can't confirm in 6532(not released), On Win VIsta 32 bit, but with default settings, that button doesn't work - menu is not hidden.
The problem goes away if you go under Tools, Customize toolbar, General options, then change "Show main toolbar as" from the default of one wrappable toolbar to many toolbars. Even setting the option back to one wrappable toolbar does not cause the crash to occur any more.
Confirmed, with one difference, when using "many toolbars", it works, changing back to "one wrappable toolbar" it works too.

I think I reported that it doesn't work, without crash, perhaps it was not fixed completely.

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 5 guests