Copy is insanely slow

Bugs and issues.
Post Reply
Message
Author
ags1905
Posts: 37
Joined: 30.07.2020, 17:01

Copy is insanely slow

#1 Post by ags1905 » 01.03.2024, 22:45

Using FreeCommanderPortable_2024_Build_901.paf.exe

Scenario
- copying browser profile in a different location on the same disk
- disk is an SSD of 500 MiB/s read and write

Browser profile
- 1.431.918.766 bytes
- 12.343 Files, 759 Folders
- browser was not running

Results
Double Commander - 7 seconds
Windows Explorer - 9 seconds
Unreal Commander - 10 seconds
Free Commander - 600+ seconds. I stopped the copy operation at about 60% and 10 minutes. Selected copy method was Use FreeCommander.

Can someone reproduce this? Not the seconds, but the absolutely insanely long times FC manages to get compared with other file managers.
Last edited by ags1905 on 02.03.2024, 05:38, edited 1 time in total.

Karol
Posts: 969
Joined: 19.08.2007, 12:05

Re: Copy is insanely slow

#2 Post by Karol » 02.03.2024, 00:03

FC 904 64 bit
Copying from SSD to HDD
1280 files, 138 folders
15.1 GB (16.267.872.368 Bytes)

DoubleCmd: 2 min 52 sec
Windows Explorer: 2 min 59 sec
UnrealCmd: 2 min 59 sec
FreeCmd: 'Use FC' 3 min 15 sec
FreeCmd: 'Use FC - Windows method' 3 min 00 sec
FreeCmd: 'Use Windows' 2 min 55 sec

User avatar
alf5000
Posts: 554
Joined: 12.04.2012, 17:59
Location: Austria

Re: Copy is insanely slow

#3 Post by alf5000 » 03.03.2024, 18:03

FC is noticably slower (I wouldn't call it insanely slow) especially when there are lots of small files involved.

Windows FileExplorer: 0:51min
FreeCommander: 1:41min

2,27GB
19.511 files, 2.713 folders

I admit faster is better, but ....
(win10pro x64) - (latest FCXE x64 portable)

mumajs
Posts: 30
Joined: 06.12.2017, 20:16

Re: Copy is insanely slow

#4 Post by mumajs » 23.05.2024, 08:16

Improvement in FC copy (using FC method) can be achieved by selecting "Copy" tab instead of "Files" in the copy window. You will see that it is much faster be on "Copy" then on "Files" with the list of files. Next impropvement you can achieve by disabling refresh of files completely. If you are copying more files from one panel to other and you can see how FC stop for a while when refreshing the panels. It is anoying to remember to click on "Copy" tab from "Files" which opens automatically, but I did not find how to disable the feature. Seems that handling the listbox with the files which are copied makes delays in copy process.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests