why (file/ folder) (move/copy) behavior are different in fc and win-explo

Discussion, questions and support.
Post Reply
Message
Author
vsrawat
Posts: 182
Joined: 05.11.2009, 21:09

why (file/ folder) (move/copy) behavior are different in fc and win-explo

#1 Post by vsrawat » 21.02.2021, 07:34

in fc as well as in windows explorer, we can just drag drop file from anywhere to anywhere.

but why (file/ folder) (move/copy) behavior are different in fc and windows explorer in the sense that if just drag drop a folder in fc, it is not moved, it is actually copied. and we need to press a qualifier key (Control or Shift) to specify whether we want to copy or more?

I think normal drag-drop should move the folder, should not copy it. We should press qualifier key only if we want to copy (not move). That is the default behavior in windows explorer. Why fc chose to make it different.

Thanks.
--
Rawat

User avatar
Dreamer
Site Admin
Posts: 4672
Joined: 19.08.2007, 23:40

Re: why (file/ folder) (move/copy) behavior are different in fc and win-explo

#2 Post by Dreamer » 21.02.2021, 16:37

In FreeCommander it works the same as in Windows Explorer.

If you drag item to the same drive/disk, it's moved by default, if you drag it to different drive/disk, it's copied by default. I just re-checked it in both programs.

Check the options in Settings > File-folder operations > Drag&Drop - option "Always perform copy operation..." should be disabled.

If you want to always move any item to any disk, you can use the right mouse button to drag and then click to move, or use option "Show popup menu for left button drop", to have the same behavior for the left button.

If it still doesn't work good, upgrade to the latest FC version and then provide more information, steps to reproduce, if you're using local drive or not...

vsrawat
Posts: 182
Joined: 05.11.2009, 21:09

Re: why (file/ folder) (move/copy) behavior are different in fc and win-explo

#3 Post by vsrawat » 21.02.2021, 16:50

both settings are already as per you described.

I changed settings, applied, changed them again to what it were earlier and as you described.

Now I left-click moved two folders and it worked correctly.

previously, I often and always faced problem of getting copied instead of moved.

Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 15 guests