843 - Thumbnails border and background bug

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

843 - Thumbnails border and background bug

#1 Post by Dreamer » 19.02.2021, 19:44

To reproduce:
- use default settings
- use dark grey flat default color scheme
- for thumbnails use options "transparent" and "no border"
- place some files from FC install folder and some others (.exe, .lnk, .sld, .txt, .rtf) to one folder
- switch to thumbnails view and use size 64 or larger
= some thumbnails have a white border and black background

In Windows Explorer, with "medium icons" option there are no borders, with "large icons" option borders are shown too, but they are thinner and grey, not white - and it has a transparent background for all icons, not black as in FC.

With the size 48 in FC thumbnails are OK.
FC Screenshot_02192021_191842.png
FC 843 and 842 donor 64-bit, Windows 10 20H2 64-bit.

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#2 Post by Dreamer » 24.02.2021, 21:38

8441 - original bug fixed, thanks, but transparency is not good, white borders.
FC Screenshot_02242021_213806.png

Marek
Author
Author
Posts: 3142
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: 843 - Thumbnails border and background bug

#3 Post by Marek » 25.02.2021, 22:04

I think, I can not currently better.
Maybe some icons are not optimized for dark background.

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#4 Post by Dreamer » 25.02.2021, 22:39

The same icons, with the same size were OK in 840, they are OK also in Explorer - with dark background in both cases.

FC 840 public 32-bit:
FC Screenshot_02252021_222739.png
Windows Explorer:
FC Screenshot_02252021_222856.png
FC 8441:
FC Screenshot_02242021_213806.png

Marek
Author
Author
Posts: 3142
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: 843 - Thumbnails border and background bug

#5 Post by Marek » 27.02.2021, 15:27

Thanks for the hint with 840.
I optimized the thumbnails display and something went wrong.
I hope now it is ok again.

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#6 Post by Dreamer » 27.02.2021, 20:18

You're welcome. In 8442 it's better, almost perfect, lnk icons have the same size now, but the icons have some strange grey border now, it's visible on C64, FC XE blue (old FC icon) and also on XnView.

840
FC icons 840 Screenshot_02272021_200208.png
8442
FC icons 8442 Screenshot_02272021_200211.png
It's not just lnk icons, one example of the exe icons, 840 vs 8442 (size is 96 in both programs).
FC icons c64 Screenshot_02272021_201623.png
New issue, the icon size is always the same, even if using 512, in 8442 the icons size is the same, small, tested lnk, exe, dll. (created new topic)

Marek
Author
Author
Posts: 3142
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: 843 - Thumbnails border and background bug

#7 Post by Marek » 06.03.2021, 17:11

Please check again.

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#8 Post by Dreamer » 06.03.2021, 21:46

I have a problem with thumbnails now, but some are loaded in 8443 and they are not OK.
FC Screenshot_03062021_214539.png
FC Screenshot_03062021_214539.png (20.58 KiB) Viewed 3512 times

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#9 Post by Dreamer » 07.03.2021, 00:10

Same after PC restart, 8443+.

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#10 Post by Dreamer » 07.03.2021, 10:16

In 843+ it's really strange, one time I start FC and I have NO thumbnails, then I start it again and I have all thumbnails.

Anyway, even with all thumbnails I have some folder thumbnails broken, small and with broken transparency, so something is wrong.

Marek
Author
Author
Posts: 3142
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: 843 - Thumbnails border and background bug

#11 Post by Marek » 07.03.2021, 21:20

Strange, I have no problems:
screen_20210307_211843.png

User avatar
Dreamer
Site Admin
Posts: 4729
Joined: 19.08.2007, 23:40

Re: 843 - Thumbnails border and background bug

#12 Post by Dreamer » 07.03.2021, 23:20

Your thumbnail is for exe file, my thumb is for lnk, I tried to check the xnview.exe, but after 15 minutes still no icon.

EDIT: OK, after some 30 minutes xnview.exe icon is loaded and it's broken, white borders, the same as the sld one on screenshot above.


Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests