My tooldbar's Dos-Admin doesn't open in current folder

Discussion, questions and support.
Post Reply
Message
Author
vsrawat
Posts: 182
Joined: 05.11.2009, 21:09

My tooldbar's Dos-Admin doesn't open in current folder

#1 Post by vsrawat » 21.02.2021, 07:38

I think it is not fc's default, I had created this toolbar entry following suggestions at this site.

My tooldbar does show "Dos-Admin" but it doesn't open in current folder, in opens in system32, I think.

I have defined in the MYTools entry script the following: (you would understand where what should be)
%windir%\system32\cmd.exe
%ActiveDir%

What have I done wrongly, or what more information would you require to correct it?

Thanks.
--
Rawat

Marek
Author
Author
Posts: 3142
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: My tooldbar's Dos-Admin doesn't open in current folder

#2 Post by Marek » 21.02.2021, 09:06

Press SHIFT key and select "Tools->DOS box".
If you have defined default button for DOS-Box - click on the button with pressed SHIFT key.

If you like your own button in the favorite toolbar:
- Name: DOS-Admin
- Program or folder: cmd.exe
- Parameter: /k "cd /d %ActivDir%"
- 'With "Run as" dialog' must be checked

Forez
Posts: 536
Joined: 30.01.2016, 12:05
Location: In front of a PC monitor

Re: My tooldbar's Dos-Admin doesn't open in current folder

#3 Post by Forez » 22.02.2021, 01:45

Marek wrote: 21.02.2021, 09:06 [...]
- Parameter: /k "cd /d %ActivDir%"
[...]
Great



How about running this inform of a LNK file?

I have the >>Target:<< parameter for my shortcuts set to

Code: Select all

C:\Windows\SysWOW64\cmd.exe /K "cd /d C:\"
C:\Windows\System32\cmd.exe /K "cd /d C:\"
and the both work - in that the open CommandPrompt with the path of

Code: Select all

C:\
But is there a way that I could put somehow reworked LNK in a folder and after running it have the CMD window open in this location?

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests